[3.5.1 -> 4.1.1] Post upgrade everything 404s

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

[3.5.1 -> 4.1.1] Post upgrade everything 404s

Nathan Keiter

We just upgraded one of our servers straight from 3.5.1 to 4.1.1. After the upgrade we performed a re-index and then flushed the caches.

 

Every single page whether front-end or back-end returns 404.

 

How do we fix?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/e421b759f26a4b36b0d0660632e4b042%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

Maarten Daalder
We had the same problem, 4.1.2 fixes this.

On Wednesday, 29 November 2017 15:21:51 UTC+1, Nathan Keiter wrote:

We just upgraded one of our servers straight from 3.5.1 to 4.1.1. After the upgrade we performed a re-index and then flushed the caches.

 

Every single page whether front-end or back-end returns 404.

 

How do we fix?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/ff209508-4aa0-427d-a53a-064cf1c2bc11%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

Nathan Keiter

We have another server where we upgraded from 3.5.1 -> 4.0.1 -> 4.1.1 which does not have this issue.

 

Is it specific to skipping over 4.0.1???

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Maarten Daalder
Sent: Wednesday, November 29, 2017 9:23 AM
To: dotCMS User Group
Subject: [dotcms] Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

 

We had the same problem, 4.1.2 fixes this.

On Wednesday, 29 November 2017 15:21:51 UTC+1, Nathan Keiter wrote:

We just upgraded one of our servers straight from 3.5.1 to 4.1.1. After the upgrade we performed a re-index and then flushed the caches.

 

Every single page whether front-end or back-end returns 404.

 

How do we fix?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/ff209508-4aa0-427d-a53a-064cf1c2bc11%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/c62e6ad20ef94298929a2f2a5361d399%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

Yasin
In reply to this post by Nathan Keiter
We had the same issue when we upgraded from 3.7.1 to 4.2.0 directly => http://forumarchive.dotcms.com/All-page-assets-returning-404-Page-not-found-error-after-dotCMS-upgrade-td5734302.html

Couple days after 4.2.1 was released and that fixed this problem for us.

It might have to do with license issue that was fixed in the 4.2.1 release, do you use MS SQL? https://github.com/dotCMS/core/pull/13009/commits/92608458ef77dbe4f42b5f26f1ae89d3e2efe552 

Op woensdag 29 november 2017 15:21:51 UTC+1 schreef Nathan Keiter:

We just upgraded one of our servers straight from 3.5.1 to 4.1.1. After the upgrade we performed a re-index and then flushed the caches.

 

Every single page whether front-end or back-end returns 404.

 

How do we fix?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/635e7ecf-1027-4d9d-9de3-f78e9a89a70f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

Maarten Daalder
In reply to this post by Nathan Keiter
Hi Nathan,

I'm not sure, I wasn't involved with our upgrades.
I think that in our case it was the license comparison bug (it evaluated that you needed a higher license to use SQLServer than specified on the website and previous versions).


On Wednesday, 29 November 2017 15:25:14 UTC+1, Nathan Keiter wrote:

We have another server where we upgraded from 3.5.1 -> 4.0.1 -> 4.1.1 which does not have this issue.

 

Is it specific to skipping over 4.0.1???

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

From: <a href="javascript:" target="_blank" gdf-obfuscated-mailto="2FTpdcj7AgAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@... [mailto:<a href="javascript:" target="_blank" gdf-obfuscated-mailto="2FTpdcj7AgAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@googlegroups.com] On Behalf Of Maarten Daalder
Sent: Wednesday, November 29, 2017 9:23 AM
To: dotCMS User Group
Subject: [dotcms] Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

 

We had the same problem, 4.1.2 fixes this.

On Wednesday, 29 November 2017 15:21:51 UTC+1, Nathan Keiter wrote:

We just upgraded one of our servers straight from 3.5.1 to 4.1.1. After the upgrade we performed a re-index and then flushed the caches.

 

Every single page whether front-end or back-end returns 404.

 

How do we fix?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

--
<a href="http://dotcms.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="2FTpdcj7AgAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dotcms+un...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="2FTpdcj7AgAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@....
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/ff209508-4aa0-427d-a53a-064cf1c2bc11%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/ff209508-4aa0-427d-a53a-064cf1c2bc11%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/ff209508-4aa0-427d-a53a-064cf1c2bc11%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;"> https://groups.google.com/d/msgid/dotcms/ff209508-4aa0-427d-a53a-064cf1c2bc11%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/749fcf43-82c4-4bf0-8f27-580cae71b9e8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

Nathan Keiter
In reply to this post by Yasin

Oracle DB.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Yasin
Sent: Wednesday, November 29, 2017 10:14 AM
To: dotCMS User Group
Subject: [dotcms] Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

 

We had the same issue when we upgraded from 3.7.1 to 4.2.0 directly => http://forumarchive.dotcms.com/All-page-assets-returning-404-Page-not-found-error-after-dotCMS-upgrade-td5734302.html

 

Couple days after 4.2.1 was released and that fixed this problem for us.

 

It might have to do with license issue that was fixed in the 4.2.1 release, do you use MS SQL? https://github.com/dotCMS/core/pull/13009/commits/92608458ef77dbe4f42b5f26f1ae89d3e2efe552 


Op woensdag 29 november 2017 15:21:51 UTC+1 schreef Nathan Keiter:

We just upgraded one of our servers straight from 3.5.1 to 4.1.1. After the upgrade we performed a re-index and then flushed the caches.

 

Every single page whether front-end or back-end returns 404.

 

How do we fix?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/635e7ecf-1027-4d9d-9de3-f78e9a89a70f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/71e1019c42cb4fd79bb1ce6e7c3f00f2%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

Maarten Daalder
In the same commit OracleDB was also affected.

On Wednesday, 29 November 2017 16:24:27 UTC+1, Nathan Keiter wrote:

Oracle DB.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

From: <a href="javascript:" target="_blank" gdf-obfuscated-mailto="N_9Y1gP_AgAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@... [mailto:<a href="javascript:" target="_blank" gdf-obfuscated-mailto="N_9Y1gP_AgAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@googlegroups.com] On Behalf Of Yasin
Sent: Wednesday, November 29, 2017 10:14 AM
To: dotCMS User Group
Subject: [dotcms] Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

 

We had the same issue when we upgraded from 3.7.1 to 4.2.0 directly => <a href="http://forumarchive.dotcms.com/All-page-assets-returning-404-Page-not-found-error-after-dotCMS-upgrade-td5734302.html" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fforumarchive.dotcms.com%2FAll-page-assets-returning-404-Page-not-found-error-after-dotCMS-upgrade-td5734302.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHVBQx9SnTBxvVNqQairJ2UMVIXvw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fforumarchive.dotcms.com%2FAll-page-assets-returning-404-Page-not-found-error-after-dotCMS-upgrade-td5734302.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHVBQx9SnTBxvVNqQairJ2UMVIXvw&#39;;return true;">http://forumarchive.dotcms.com/All-page-assets-returning-404-Page-not-found-error-after-dotCMS-upgrade-td5734302.html

 

Couple days after 4.2.1 was released and that fixed this problem for us.

 

It might have to do with license issue that was fixed in the 4.2.1 release, do you use MS SQL? <a href="https://github.com/dotCMS/core/pull/13009/commits/92608458ef77dbe4f42b5f26f1ae89d3e2efe552" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2FdotCMS%2Fcore%2Fpull%2F13009%2Fcommits%2F92608458ef77dbe4f42b5f26f1ae89d3e2efe552\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxLb9q-IpbvorSNIsbFfrTnqj2HQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2FdotCMS%2Fcore%2Fpull%2F13009%2Fcommits%2F92608458ef77dbe4f42b5f26f1ae89d3e2efe552\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxLb9q-IpbvorSNIsbFfrTnqj2HQ&#39;;return true;">https://github.com/dotCMS/core/pull/13009/commits/92608458ef77dbe4f42b5f26f1ae89d3e2efe552 


Op woensdag 29 november 2017 15:21:51 UTC+1 schreef Nathan Keiter:

We just upgraded one of our servers straight from 3.5.1 to 4.1.1. After the upgrade we performed a re-index and then flushed the caches.

 

Every single page whether front-end or back-end returns 404.

 

How do we fix?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

--
<a href="http://dotcms.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="N_9Y1gP_AgAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dotcms+un...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="N_9Y1gP_AgAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@....
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/635e7ecf-1027-4d9d-9de3-f78e9a89a70f%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/635e7ecf-1027-4d9d-9de3-f78e9a89a70f%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/635e7ecf-1027-4d9d-9de3-f78e9a89a70f%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;"> https://groups.google.com/d/msgid/dotcms/635e7ecf-1027-4d9d-9de3-f78e9a89a70f%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/1177b32f-1679-4d99-8fd8-932dd7f6f170%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

Nathan Keiter

Ok Maarten. I’m working with dotCMS support now.

 

I’m just wondering why we didn’t encounter this on our other server…

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Maarten Daalder
Sent: Wednesday, November 29, 2017 10:48 AM
To: dotCMS User Group
Subject: Re: [dotcms] Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

 

In the same commit OracleDB was also affected.

On Wednesday, 29 November 2017 16:24:27 UTC+1, Nathan Keiter wrote:

Oracle DB.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: <a href="javascript:" target="_blank">dot...@... [mailto:<a href="javascript:" target="_blank">dot...@...] On Behalf Of Yasin
Sent: Wednesday, November 29, 2017 10:14 AM
To: dotCMS User Group
Subject: [dotcms] Re: [3.5.1 -> 4.1.1] Post upgrade everything 404s

 

We had the same issue when we upgraded from 3.7.1 to 4.2.0 directly => http://forumarchive.dotcms.com/All-page-assets-returning-404-Page-not-found-error-after-dotCMS-upgrade-td5734302.html

 

Couple days after 4.2.1 was released and that fixed this problem for us.

 

It might have to do with license issue that was fixed in the 4.2.1 release, do you use MS SQL? https://github.com/dotCMS/core/pull/13009/commits/92608458ef77dbe4f42b5f26f1ae89d3e2efe552 


Op woensdag 29 november 2017 15:21:51 UTC+1 schreef Nathan Keiter:

We just upgraded one of our servers straight from 3.5.1 to 4.1.1. After the upgrade we performed a re-index and then flushed the caches.

 

Every single page whether front-end or back-end returns 404.

 

How do we fix?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank">dotcms+un...@....
To post to this group, send email to <a href="javascript:" target="_blank">dot...@....
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/635e7ecf-1027-4d9d-9de3-f78e9a89a70f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/1177b32f-1679-4d99-8fd8-932dd7f6f170%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/c36485805fc044ce8962d8805672aace%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.