All page assets returning 404 Page not found error after dotCMS upgrade

classic Classic list List threaded Threaded
18 messages Options
Reply | Threaded
Open this post in threaded view
|

All page assets returning 404 Page not found error after dotCMS upgrade

Yasin
Hi,

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

The upgrade went fine, all SQL scripts etc. have been executed successfully.

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.

For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

Did anyone experience this before or could anyone tell us how we can solve this?

The assets folder etc. is present and all permissions are set correctly.

Thank you.





--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

RE: All page assets returning 404 Page not found error after dotCMS upgrade

Nathan Keiter

Did you do a full reindex after upgrading?

 

Sounds like a bad index.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:27 AM
To: dotCMS User Group
Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi,

 

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

 

The upgrade went fine, all SQL scripts etc. have been executed successfully.

 

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.


For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

 

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

 

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

 

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

 

Did anyone experience this before or could anyone tell us how we can solve this?

 

The assets folder etc. is present and all permissions are set correctly.

 

Thank you.

 

 

 

 

 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/afa3e6dcb297411e93465e130de108b6%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

Yasin
Hi Nathan,

Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.

Thanks.

Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:

Did you do a full reindex after upgrading?

 

Sounds like a bad index.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

From: <a href="javascript:" target="_blank" gdf-obfuscated-mailto="eZe_-40iAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@... [mailto:<a href="javascript:" target="_blank" gdf-obfuscated-mailto="eZe_-40iAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@googlegroups.com] On Behalf Of <a href="javascript:" target="_blank" gdf-obfuscated-mailto="eZe_-40iAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dile...@...
Sent: Wednesday, November 08, 2017 10:27 AM
To: dotCMS User Group
Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi,

 

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

 

The upgrade went fine, all SQL scripts etc. have been executed successfully.

 

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.


For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

 

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

 

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

 

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

 

Did anyone experience this before or could anyone tell us how we can solve this?

 

The assets folder etc. is present and all permissions are set correctly.

 

Thank you.

 

 

 

 

 

--
<a href="http://dotcms.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="eZe_-40iAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dotcms+un...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="eZe_-40iAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@....
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;"> https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

RE: All page assets returning 404 Page not found error after dotCMS upgrade

Nathan Keiter

Did you upgrade all your page assets to page contentlets?

 

I can’t remember, but at some point that may have been required as page assets are deprecated.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:31 AM
To: dotCMS User Group
Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi Nathan,


Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.

 

Thanks.

Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:

Did you do a full reindex after upgrading?

 

Sounds like a bad index.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: <a href="javascript:" target="_blank">dot...@... [mailto:<a href="javascript:" target="_blank">dot...@...] On Behalf Of <a href="javascript:" target="_blank">dile...@...
Sent: Wednesday, November 08, 2017 10:27 AM
To: dotCMS User Group
Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi,

 

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

 

The upgrade went fine, all SQL scripts etc. have been executed successfully.

 

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.


For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

 

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

 

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

 

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

 

Did anyone experience this before or could anyone tell us how we can solve this?

 

The assets folder etc. is present and all permissions are set correctly.

 

Thank you.

 

 

 

 

 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank">dotcms+un...@....
To post to this group, send email to <a href="javascript:" target="_blank">dot...@....
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/e9511d978bd24d03939669d61d1c9f5f%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

Yasin
Hi Nathan,

I think you are referring to https://dotcms.com/docs/latest/upgrading-to-dotcms-4-0#RemovedFeatures (latest point: "Legacy HTML Pages")? This was the case for dotCMS versions prior to version 3.1 and we never had that version (started with dotCMS 3.6).

When I go to the content overview in dotCMS and select "Page Asset" from the dropdown, I see a listing of all the Page Assets.

Thanks.



Op woensdag 8 november 2017 16:33:06 UTC+1 schreef Nathan Keiter:

Did you upgrade all your page assets to page contentlets?

 

I can’t remember, but at some point that may have been required as page assets are deprecated.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

From: <a href="javascript:" target="_blank" gdf-obfuscated-mailto="WGUrj8EiAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@... [mailto:<a href="javascript:" target="_blank" gdf-obfuscated-mailto="WGUrj8EiAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@googlegroups.com] On Behalf Of <a href="javascript:" target="_blank" gdf-obfuscated-mailto="WGUrj8EiAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dile...@...
Sent: Wednesday, November 08, 2017 10:31 AM
To: dotCMS User Group
Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi Nathan,


Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.

 

Thanks.

Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:

Did you do a full reindex after upgrading?

 

Sounds like a bad index.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

From: [hidden email] [mailto:dot...@googlegroups.com] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:27 AM
To: dotCMS User Group
Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi,

 

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

 

The upgrade went fine, all SQL scripts etc. have been executed successfully.

 

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.


For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

 

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

 

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

 

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

 

Did anyone experience this before or could anyone tell us how we can solve this?

 

The assets folder etc. is present and all permissions are set correctly.

 

Thank you.

 

 

 

 

 

--
<a href="http://dotcms.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;"> https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;"> https://groups.google.com/d/optout.

--
<a href="http://dotcms.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="WGUrj8EiAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dotcms+un...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="WGUrj8EiAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@....
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;"> https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/1615c341-9967-4d35-8fd2-a0c03b24ec25%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

RE: All page assets returning 404 Page not found error after dotCMS upgrade

Nathan Keiter

Ok. I have one more idea. Flush all caches.

 

If that doesn’t help, I don’t know what else to do. Perhaps a dotCMS team member can help.

 

No errors in the log?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:42 AM
To: dotCMS User Group
Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi Nathan,

 

I think you are referring to https://dotcms.com/docs/latest/upgrading-to-dotcms-4-0#RemovedFeatures (latest point: "Legacy HTML Pages")? This was the case for dotCMS versions prior to version 3.1 and we never had that version (started with dotCMS 3.6).

 

When I go to the content overview in dotCMS and select "Page Asset" from the dropdown, I see a listing of all the Page Assets.

 

Thanks.

 



Op woensdag 8 november 2017 16:33:06 UTC+1 schreef Nathan Keiter:

Did you upgrade all your page assets to page contentlets?

 

I can’t remember, but at some point that may have been required as page assets are deprecated.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: <a href="javascript:" target="_blank">dot...@... [mailto:<a href="javascript:" target="_blank">dot...@...] On Behalf Of <a href="javascript:" target="_blank">dile...@...
Sent: Wednesday, November 08, 2017 10:31 AM
To: dotCMS User Group
Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi Nathan,


Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.

 

Thanks.

Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:

Did you do a full reindex after upgrading?

 

Sounds like a bad index.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [[hidden email]] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:27 AM
To: dotCMS User Group
Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi,

 

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

 

The upgrade went fine, all SQL scripts etc. have been executed successfully.

 

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.


For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

 

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

 

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

 

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

 

Did anyone experience this before or could anyone tell us how we can solve this?

 

The assets folder etc. is present and all permissions are set correctly.

 

Thank you.

 

 

 

 

 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank">dotcms+un...@....
To post to this group, send email to <a href="javascript:" target="_blank">dot...@....
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/1615c341-9967-4d35-8fd2-a0c03b24ec25%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/034d5faf03df4aa5ada3c31f67e9393d%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

Yasin
We already did that multiple times as well, no result.

The strange part is that no exceptions or errors are occurring (at least not visible in any of the log files).

Thank you.

Op woensdag 8 november 2017 16:45:01 UTC+1 schreef Nathan Keiter:

Ok. I have one more idea. Flush all caches.

 

If that doesn’t help, I don’t know what else to do. Perhaps a dotCMS team member can help.

 

No errors in the log?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

From: <a href="javascript:" target="_blank" gdf-obfuscated-mailto="EWqvOmgjAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@... [mailto:<a href="javascript:" target="_blank" gdf-obfuscated-mailto="EWqvOmgjAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@googlegroups.com] On Behalf Of <a href="javascript:" target="_blank" gdf-obfuscated-mailto="EWqvOmgjAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dile...@...
Sent: Wednesday, November 08, 2017 10:42 AM
To: dotCMS User Group
Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi Nathan,

 

I think you are referring to <a href="https://dotcms.com/docs/latest/upgrading-to-dotcms-4-0#RemovedFeatures" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fdotcms.com%2Fdocs%2Flatest%2Fupgrading-to-dotcms-4-0%23RemovedFeatures\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNF9uuD0-6ETZpTAUJJvJHKrqzxUwQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fdotcms.com%2Fdocs%2Flatest%2Fupgrading-to-dotcms-4-0%23RemovedFeatures\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNF9uuD0-6ETZpTAUJJvJHKrqzxUwQ&#39;;return true;">https://dotcms.com/docs/latest/upgrading-to-dotcms-4-0#RemovedFeatures (latest point: "Legacy HTML Pages")? This was the case for dotCMS versions <a href="https://dotcms.com/docs/3.6/latest/bulk-legacy-html-page-migration.html" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fdotcms.com%2Fdocs%2F3.6%2Flatest%2Fbulk-legacy-html-page-migration.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEh2uRKpu7c1t7YBbpLlVivQesStA&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fdotcms.com%2Fdocs%2F3.6%2Flatest%2Fbulk-legacy-html-page-migration.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEh2uRKpu7c1t7YBbpLlVivQesStA&#39;;return true;"> prior to version 3.1 and we never had that version (started with dotCMS 3.6).

 

When I go to the content overview in dotCMS and select "Page Asset" from the dropdown, I see a listing of all the Page Assets.

 

Thanks.

 



Op woensdag 8 november 2017 16:33:06 UTC+1 schreef Nathan Keiter:

Did you upgrade all your page assets to page contentlets?

 

I can’t remember, but at some point that may have been required as page assets are deprecated.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

From: [hidden email] [mailto:dot...@googlegroups.com] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:31 AM
To: dotCMS User Group
Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi Nathan,


Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.

 

Thanks.

Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:

Did you do a full reindex after upgrading?

 

Sounds like a bad index.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

From: [hidden email] [mailto:dot...@googlegroups.com] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:27 AM
To: dotCMS User Group
Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi,

 

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

 

The upgrade went fine, all SQL scripts etc. have been executed successfully.

 

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.


For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

 

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

 

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

 

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

 

Did anyone experience this before or could anyone tell us how we can solve this?

 

The assets folder etc. is present and all permissions are set correctly.

 

Thank you.

 

 

 

 

 

--
<a href="http://dotcms.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;"> https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;"> https://groups.google.com/d/optout.

--
<a href="http://dotcms.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;"> https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;"> https://groups.google.com/d/optout.

--
<a href="http://dotcms.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="EWqvOmgjAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dotcms+un...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="EWqvOmgjAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@....
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/1615c341-9967-4d35-8fd2-a0c03b24ec25%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/1615c341-9967-4d35-8fd2-a0c03b24ec25%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/1615c341-9967-4d35-8fd2-a0c03b24ec25%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;"> https://groups.google.com/d/msgid/dotcms/1615c341-9967-4d35-8fd2-a0c03b24ec25%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/50507a9c-250b-4cf1-b288-3fd947d62706%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

RE: All page assets returning 404 Page not found error after dotCMS upgrade

Nathan Keiter

One of the guys on my team said maybe it’s a Tomcat configuration issue; web.xml, server.xml etc. File permissions ok on the box?

 

4.x does ship with a new version of Tomcat I believe.  However if you are running from distribution and deployed via the provided scripts, I’m not sure how it would get corrupted.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:48 AM
To: dotCMS User Group
Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

We already did that multiple times as well, no result.

 

The strange part is that no exceptions or errors are occurring (at least not visible in any of the log files).

 

Thank you.

Op woensdag 8 november 2017 16:45:01 UTC+1 schreef Nathan Keiter:

Ok. I have one more idea. Flush all caches.

 

If that doesn’t help, I don’t know what else to do. Perhaps a dotCMS team member can help.

 

No errors in the log?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: <a href="javascript:" target="_blank">dot...@... [mailto:<a href="javascript:" target="_blank">dot...@...] On Behalf Of <a href="javascript:" target="_blank">dile...@...
Sent: Wednesday, November 08, 2017 10:42 AM
To: dotCMS User Group
Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi Nathan,

 

I think you are referring to https://dotcms.com/docs/latest/upgrading-to-dotcms-4-0#RemovedFeatures (latest point: "Legacy HTML Pages")? This was the case for dotCMS versions prior to version 3.1 and we never had that version (started with dotCMS 3.6).

 

When I go to the content overview in dotCMS and select "Page Asset" from the dropdown, I see a listing of all the Page Assets.

 

Thanks.

 



Op woensdag 8 november 2017 16:33:06 UTC+1 schreef Nathan Keiter:

Did you upgrade all your page assets to page contentlets?

 

I can’t remember, but at some point that may have been required as page assets are deprecated.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [[hidden email]] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:31 AM
To: dotCMS User Group
Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi Nathan,


Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.

 

Thanks.

Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:

Did you do a full reindex after upgrading?

 

Sounds like a bad index.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [[hidden email]] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:27 AM
To: dotCMS User Group
Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi,

 

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

 

The upgrade went fine, all SQL scripts etc. have been executed successfully.

 

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.


For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

 

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

 

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

 

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

 

Did anyone experience this before or could anyone tell us how we can solve this?

 

The assets folder etc. is present and all permissions are set correctly.

 

Thank you.

 

 

 

 

 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank">dotcms+un...@....
To post to this group, send email to <a href="javascript:" target="_blank">dot...@....
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/1615c341-9967-4d35-8fd2-a0c03b24ec25%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/50507a9c-250b-4cf1-b288-3fd947d62706%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/d22dcd6056df4d60b59210397b2ac3d2%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

Mark Pitely
In reply to this post by Yasin
Are you using a non-standard html page extension? (i.e. .dot or something) else? Or no page extension?

Mark Pitely
Marywood University

On Wed, Nov 8, 2017 at 10:47 AM, <[hidden email]> wrote:
We already did that multiple times as well, no result.

The strange part is that no exceptions or errors are occurring (at least not visible in any of the log files).

Thank you.

Op woensdag 8 november 2017 16:45:01 UTC+1 schreef Nathan Keiter:

Ok. I have one more idea. Flush all caches.

 

If that doesn’t help, I don’t know what else to do. Perhaps a dotCMS team member can help.

 

No errors in the log?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: <a href="tel:(717)%20337-6993" value="+17173376993" target="_blank">717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]m] On Behalf Of [hidden email]


Sent: Wednesday, November 08, 2017 10:42 AM
To: dotCMS User Group
Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi Nathan,

 

I think you are referring to https://dotcms.com/docs/latest/upgrading-to-dotcms-4-0#RemovedFeatures (latest point: "Legacy HTML Pages")? This was the case for dotCMS versions prior to version 3.1 and we never had that version (started with dotCMS 3.6).

 

When I go to the content overview in dotCMS and select "Page Asset" from the dropdown, I see a listing of all the Page Assets.

 

Thanks.

 



Op woensdag 8 november 2017 16:33:06 UTC+1 schreef Nathan Keiter:

Did you upgrade all your page assets to page contentlets?

 

I can’t remember, but at some point that may have been required as page assets are deprecated.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: <a href="tel:(717)%20337-6993" value="+17173376993" target="_blank">717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]m] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:31 AM
To: dotCMS User Group
Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi Nathan,


Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.

 

Thanks.

Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:

Did you do a full reindex after upgrading?

 

Sounds like a bad index.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: <a href="tel:(717)%20337-6993" value="+17173376993" target="_blank">717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]m] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:27 AM
To: dotCMS User Group
Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi,

 

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

 

The upgrade went fine, all SQL scripts etc. have been executed successfully.

 

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.


For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

 

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

 

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

 

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

 

Did anyone experience this before or could anyone tell us how we can solve this?

 

The assets folder etc. is present and all permissions are set correctly.

 

Thank you.

 

 

 

 

 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/1615c341-9967-4d35-8fd2-a0c03b24ec25%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/50507a9c-250b-4cf1-b288-3fd947d62706%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CAFeiKqPwqTLN4PNW2tPZK4jwLThG-fBSSVkf5f8CnhFT8pxA%3Dg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

wezell1
In reply to this post by Nathan Keiter
What license level and db are you using?  We found an issue with that in 4.2.0 that is going to necessitate a hotfix or a move to an upcoming 4.2.1 release if you are being bit by it. 


On Wed, Nov 8, 2017 at 10:33 AM, Nathan Keiter <[hidden email]> wrote:

Did you upgrade all your page assets to page contentlets?

 

I can’t remember, but at some point that may have been required as page assets are deprecated.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: <a href="tel:(717)%20337-6993" value="+17173376993" target="_blank">717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:31 AM
To: dotCMS User Group
Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi Nathan,


Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.

 

Thanks.

Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:

Did you do a full reindex after upgrading?

 

Sounds like a bad index.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: <a href="tel:(717)%20337-6993" value="+17173376993" target="_blank">717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:dot...@googlegroups.com] On Behalf Of [hidden email]
Sent: Wednesday, November 08, 2017 10:27 AM
To: dotCMS User Group
Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade

 

Hi,

 

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

 

The upgrade went fine, all SQL scripts etc. have been executed successfully.

 

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.


For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

 

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

 

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

 

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

 

Did anyone experience this before or could anyone tell us how we can solve this?

 

The assets folder etc. is present and all permissions are set correctly.

 

Thank you.

 

 

 

 

 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/e9511d978bd24d03939669d61d1c9f5f%40exch13c.ms.gettysburg.edu.

For more options, visit https://groups.google.com/d/optout.



--



3059 Grand Avenue
Suite 410-B
Miami FL 33133
Main: 
305-900-2001 | Direct: 978.294.9429

   

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CAPL0VyGYis2Zo2XODaaJkU%3DNqRqHRw2Q_0V-nc8_c2mVzMrcYg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

Yasin
In reply to this post by Mark Pitely
We use .html as extension, example: page title Contact and url contact.html

Op woensdag 8 november 2017 16:51:21 UTC+1 schreef Mark Pitely:

> Are you using a non-standard html page extension? (i.e. .dot or something) else? Or no page extension?
>
> Mark Pitely
> Marywood University
>
>
>
> On Wed, Nov 8, 2017 at 10:47 AM,  <[hidden email]> wrote:
>
> We already did that multiple times as well, no result.
>
>
> The strange part is that no exceptions or errors are occurring (at least not visible in any of the log files).
>
>
> Thank you.
>
> Op woensdag 8 november 2017 16:45:01 UTC+1 schreef Nathan Keiter:
>
>
>
>
>
>
>
>
>
>
> Ok. I have one more idea. Flush all caches.
>
>  
>
> If that doesn’t help, I don’t know what else to do. Perhaps a dotCMS team member can help.
>
>  
>
> No errors in the log?
>
>  
>
> Nathan I. Keiter
> |
> Lead Network Applications Programmer
> |
> Benefits Advisory Council Member
> |
> I.D.E.A Council Member
>
> Gettysburg College | Information Technology | DataSystems
>
> Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
>
> Phone: 717.337.6993
>
> https://www.gettysburg.edu
>
>  
>
> From: [hidden email] [mailto:[hidden email]]
> On Behalf Of [hidden email]
>
>
>
> Sent: Wednesday, November 08, 2017 10:42 AM
>
> To: dotCMS User Group
>
> Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade
>
>
>
>
>  
>
>
>
> Hi Nathan,
>
>
>
>  
>
>
>
>
> I think you are referring to https://dotcms.com/docs/latest/upgrading-to-dotcms-4-0#RemovedFeatures (latest point: "Legacy HTML Pages")? This was the case
>  for dotCMS versions
> prior to version 3.1 and we never had that version (started with dotCMS 3.6).
>
>
>
>
>  
>
>
>
>
> When I go to the content overview in dotCMS and select "Page Asset" from the dropdown, I see a listing of all the Page Assets.
>
>
>
>
>  
>
>
>
>
> Thanks.
>
>
>
>
>  
>
>
>
>
>
>
>
>
> Op woensdag 8 november 2017 16:33:06 UTC+1 schreef Nathan Keiter:
>
>
>
>
>
> Did you upgrade all your page assets to page contentlets?
>
>  
>
> I can’t remember, but at some point that may have been required as page assets are deprecated.
>
>  
>
> Nathan I. Keiter
> |
> Lead Network Applications Programmer
> |
> Benefits Advisory Council Member
> |
> I.D.E.A Council Member
>
> Gettysburg College | Information Technology | DataSystems
>
> Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
>
> Phone: 717.337.6993
>
> https://www.gettysburg.edu
>
>  
>
> From:
> [hidden email] [mailto:[hidden email]]
> On Behalf Of [hidden email]
>
> Sent: Wednesday, November 08, 2017 10:31 AM
>
> To: dotCMS User Group
>
> Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade
>
>  
>
>
>
> Hi Nathan,
>
>
>
>
>
> Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.
>
>
>
>
>  
>
>
>
>
> Thanks.
>
>
>
> Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:
>
>
>
>
>
> Did you do a full reindex after upgrading?
>
>  
>
> Sounds like a bad index.
>
>  
>
> Nathan I. Keiter
> |
> Lead Network Applications Programmer
> |
> Benefits Advisory Council Member
> |
> I.D.E.A Council Member
>
> Gettysburg College | Information Technology | DataSystems
>
> Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
>
> Phone: 717.337.6993
>
> https://www.gettysburg.edu
>
>  
>
> From:
> [hidden email] [mailto:[hidden email]]
> On Behalf Of [hidden email]
>
> Sent: Wednesday, November 08, 2017 10:27 AM
>
> To: dotCMS User Group
>
> Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade
>
>  
>
>
>
> Hi,
>
>
>
>  
>
>
>
>
> We upgraded a dotCMS instance from 3.7.1 to 4.2.0
>
>
>
>
>  
>
>
>
>
> The upgrade went fine, all SQL scripts etc. have been executed successfully.
>
>
>
>
>  
>
>
>
>
> But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.
>
>
>
>
>
>
> For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.
>
>
>
>
>  
>
>
>
>
> Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.
>
>
>
>
>  
>
>
>
>
> However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.
>
>
>
>
>  
>
>
>
>
> We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.
>
>
>
>
>  
>
>
>
>
> Did anyone experience this before or could anyone tell us how we can solve this?
>
>
>
>
>  
>
>
>
>
> The assets folder etc. is present and all permissions are set correctly.
>
>
>
>
>  
>
>
>
>
> Thank you.
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
> --
>
>
> http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to
> [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
>
> For more options, visit
> https://groups.google.com/d/optout.
>
>
>
>
>
> --
>
>
> http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to
> [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
>
> For more options, visit
> https://groups.google.com/d/optout.
>
>
>
>
>
>
>
> --
>
> http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to
> [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/dotcms/1615c341-9967-4d35-8fd2-a0c03b24ec25%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.
>
>
>
>
>
>
>
>
>
> --
>
> http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/50507a9c-250b-4cf1-b288-3fd947d62706%40googlegroups.com.
>
>
>
> For more options, visit https://groups.google.com/d/optout.
--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/b39ddabe-2bd6-4572-be50-dded1835de8f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

Yasin
In reply to this post by wezell1
Op woensdag 8 november 2017 16:52:17 UTC+1 schreef Will Ezell:

> What license level and db are you using?  We found an issue with that in 4.2.0 that is going to necessitate a hotfix or a move to an upcoming 4.2.1 release if you are being bit by it. 
>
>
> https://github.com/dotCMS/core/pull/13009/commits/92608458ef77dbe4f42b5f26f1ae89d3e2efe552
>
>
>
> On Wed, Nov 8, 2017 at 10:33 AM, Nathan Keiter <[hidden email]> wrote:
>
>
>
>
>
>
>
>
>
>
>
> Did you upgrade all your page assets to page contentlets?
>
>  
>
> I can’t remember, but at some point that may have been required as page assets are deprecated.
>
>  
>
> Nathan I. Keiter
> |
> Lead Network Applications Programmer
> |
> Benefits Advisory Council Member
> |
> I.D.E.A Council Member
>
> Gettysburg College | Information Technology | DataSystems
>
> Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
>
> Phone: 717.337.6993
>
> https://www.gettysburg.edu
>
>  
>
> From: [hidden email] [mailto:[hidden email]]
> On Behalf Of [hidden email]
>
> Sent: Wednesday, November 08, 2017 10:31 AM
>
> To: dotCMS User Group
>
> Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade
>
>
>
>  
>
>
>
> Hi Nathan,
>
>
>
>
>
> Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.
>
>
>
>
>  
>
>
>
>
> Thanks.
>
>
>
> Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:
>
>
>
>
>
> Did you do a full reindex after upgrading?
>
>  
>
> Sounds like a bad index.
>
>  
>
> Nathan I. Keiter
> |
> Lead Network Applications Programmer
> |
> Benefits Advisory Council Member
> |
> I.D.E.A Council Member
>
> Gettysburg College | Information Technology | DataSystems
>
> Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
>
> Phone: 717.337.6993
>
> https://www.gettysburg.edu
>
>  
>
> From:
> [hidden email] [mailto:[hidden email]]
> On Behalf Of [hidden email]
>
> Sent: Wednesday, November 08, 2017 10:27 AM
>
> To: dotCMS User Group
>
> Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade
>
>  
>
>
>
> Hi,
>
>
>
>  
>
>
>
>
> We upgraded a dotCMS instance from 3.7.1 to 4.2.0
>
>
>
>
>  
>
>
>
>
> The upgrade went fine, all SQL scripts etc. have been executed successfully.
>
>
>
>
>  
>
>
>
>
> But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.
>
>
>
>
>
>
> For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.
>
>
>
>
>  
>
>
>
>
> Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.
>
>
>
>
>  
>
>
>
>
> However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.
>
>
>
>
>  
>
>
>
>
> We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.
>
>
>
>
>  
>
>
>
>
> Did anyone experience this before or could anyone tell us how we can solve this?
>
>
>
>
>  
>
>
>
>
> The assets folder etc. is present and all permissions are set correctly.
>
>
>
>
>  
>
>
>
>
> Thank you.
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
> --
>
>
> http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to
> [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
>
> For more options, visit
> https://groups.google.com/d/optout.
>
>
>
>
>
> --
>
> http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to
> [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.
>
>
>
>
>
>
>
>
>
> --
>
> http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/e9511d978bd24d03939669d61d1c9f5f%40exch13c.ms.gettysburg.edu.
>
>
>
> For more options, visit https://groups.google.com/d/optout.
>
>
>
>
>
> --
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> 3059 Grand Avenue
> Suite 410-B
> Miami FL 33133Main: 305-900-2001 | Direct: 978.294.9429
>
> [hidden email] | dotcms.com
>
>
>    
Professional with MSSQL database. We are facing 404 errors, but the commit seems to fix a redirect to no license error page?

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/cece87bc-7208-4f76-af6b-04c47a5937c9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

wezell1
Does that no_license.jsp exist?

On Wed, Nov 8, 2017 at 12:41 PM, <[hidden email]> wrote:
Op woensdag 8 november 2017 16:52:17 UTC+1 schreef Will Ezell:
> What license level and db are you using?  We found an issue with that in 4.2.0 that is going to necessitate a hotfix or a move to an upcoming 4.2.1 release if you are being bit by it. 
>
>
> https://github.com/dotCMS/core/pull/13009/commits/92608458ef77dbe4f42b5f26f1ae89d3e2efe552
>
>
>
> On Wed, Nov 8, 2017 at 10:33 AM, Nathan Keiter <[hidden email]> wrote:
>
>
>
>
>
>
>
>
>
>
>
> Did you upgrade all your page assets to page contentlets?
>
>  
>
> I can’t remember, but at some point that may have been required as page assets are deprecated.
>
>  
>
> Nathan I. Keiter
> |
> Lead Network Applications Programmer
> |
> Benefits Advisory Council Member
> |
> I.D.E.A Council Member
>
> Gettysburg College | Information Technology | DataSystems
>
> Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
>
> Phone: <a href="tel:717.337.6993" value="+17173376993">717.337.6993
>
> https://www.gettysburg.edu
>
>  
>
> From: [hidden email] [mailto:[hidden email]]
> On Behalf Of [hidden email]
>
> Sent: Wednesday, November 08, 2017 10:31 AM
>
> To: dotCMS User Group
>
> Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade
>
>
>
>  
>
>
>
> Hi Nathan,
>
>
>
>
>
> Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.
>
>
>
>
>  
>
>
>
>
> Thanks.
>
>
>
> Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:
>
>
>
>
>
> Did you do a full reindex after upgrading?
>
>  
>
> Sounds like a bad index.
>
>  
>
> Nathan I. Keiter
> |
> Lead Network Applications Programmer
> |
> Benefits Advisory Council Member
> |
> I.D.E.A Council Member
>
> Gettysburg College | Information Technology | DataSystems
>
> Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
>
> Phone: 717.337.6993
>
> https://www.gettysburg.edu
>
>  
>
> From:
> [hidden email] [mailto:[hidden email]]
> On Behalf Of [hidden email]
>
> Sent: Wednesday, November 08, 2017 10:27 AM
>
> To: dotCMS User Group
>
> Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade
>
>  
>
>
>
> Hi,
>
>
>
>  
>
>
>
>
> We upgraded a dotCMS instance from 3.7.1 to 4.2.0
>
>
>
>
>  
>
>
>
>
> The upgrade went fine, all SQL scripts etc. have been executed successfully.
>
>
>
>
>  
>
>
>
>
> But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.
>
>
>
>
>
>
> For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.
>
>
>
>
>  
>
>
>
>
> Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.
>
>
>
>
>  
>
>
>
>
> However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.
>
>
>
>
>  
>
>
>
>
> We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.
>
>
>
>
>  
>
>
>
>
> Did anyone experience this before or could anyone tell us how we can solve this?
>
>
>
>
>  
>
>
>
>
> The assets folder etc. is present and all permissions are set correctly.
>
>
>
>
>  
>
>
>
>
> Thank you.
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
> --
>
>
> http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to
> [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
>
> For more options, visit
> https://groups.google.com/d/optout.
>
>
>
>
>
> --
>
> http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to
> [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.
>
>
>
>
>
>
>
>
>
> --
>
> http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/e9511d978bd24d03939669d61d1c9f5f%40exch13c.ms.gettysburg.edu.
>
>
>
> For more options, visit https://groups.google.com/d/optout.
>
>
>
>
>
> --
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> 3059 Grand Avenue
> Suite 410-B
> Miami FL 33133Main: <a href="tel:305-900-2001" value="+13059002001">305-900-2001 | Direct: <a href="tel:978.294.9429" value="+19782949429">978.294.9429
>
> [hidden email] | dotcms.com
>
>
>    

Professional with MSSQL database. We are facing 404 errors, but the commit seems to fix a redirect to no license error page?

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/cece87bc-7208-4f76-af6b-04c47a5937c9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--



3059 Grand Avenue
Suite 410-B
Miami FL 33133
Main: 
305-900-2001 | Direct: 978.294.9429

   

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CAPL0VyE-PwUJb%3DmRPYq_bYz1bpy4QkoysMA6DVkLV-iz%3DpWg8g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

Maarten Daalder
Hi Will,

I think that is a second bug, the page is found in https://github.com/dotCMS/core/blob/master/dotCMS/src/main/webapp/html/error/no_license.jsp
But perhaps there is a filter/rewrite rule that ought to have properly redirected to it?

With kind regards,
Maarten Daalder
ISAAC

On Wednesday, 8 November 2017 18:52:04 UTC+1, Will Ezell wrote:
Does that no_license.jsp exist?

On Wed, Nov 8, 2017 at 12:41 PM, <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="uQkO-1YqAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dile...@...> wrote:
Op woensdag 8 november 2017 16:52:17 UTC+1 schreef Will Ezell:
> What license level and db are you using?  We found an issue with that in 4.2.0 that is going to necessitate a hotfix or a move to an upcoming 4.2.1 release if you are being bit by it. 
>
>
> <a href="https://github.com/dotCMS/core/pull/13009/commits/92608458ef77dbe4f42b5f26f1ae89d3e2efe552" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2FdotCMS%2Fcore%2Fpull%2F13009%2Fcommits%2F92608458ef77dbe4f42b5f26f1ae89d3e2efe552\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxLb9q-IpbvorSNIsbFfrTnqj2HQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2FdotCMS%2Fcore%2Fpull%2F13009%2Fcommits%2F92608458ef77dbe4f42b5f26f1ae89d3e2efe552\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxLb9q-IpbvorSNIsbFfrTnqj2HQ&#39;;return true;">https://github.com/dotCMS/core/pull/13009/commits/92608458ef77dbe4f42b5f26f1ae89d3e2efe552
>
>
>
> On Wed, Nov 8, 2017 at 10:33 AM, Nathan Keiter <[hidden email]> wrote:
>
>
>
>
>
>
>
>
>
>
>
> Did you upgrade all your page assets to page contentlets?
>
>  
>
> I can’t remember, but at some point that may have been required as page assets are deprecated.
>
>  
>
> Nathan I. Keiter
> |
> Lead Network Applications Programmer
> |
> Benefits Advisory Council Member
> |
> I.D.E.A Council Member
>
> Gettysburg College | Information Technology | DataSystems
>
> Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
>
> Phone: 717.337.6993
>
> <a href="https://www.gettysburg.edu" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNH08Vme5IK4KaYNCVsHJJ1QD5kAhQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNH08Vme5IK4KaYNCVsHJJ1QD5kAhQ&#39;;return true;">https://www.gettysburg.edu
>
>  
>
> From: [hidden email] [mailto:dot...@googlegroups.com]
> On Behalf Of [hidden email]
>
> Sent: Wednesday, November 08, 2017 10:31 AM
>
> To: dotCMS User Group
>
> Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade
>
>
>
>  
>
>
>
> Hi Nathan,
>
>
>
>
>
> Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.
>
>
>
>
>  
>
>
>
>
> Thanks.
>
>
>
> Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:
>
>
>
>
>
> Did you do a full reindex after upgrading?
>
>  
>
> Sounds like a bad index.
>
>  
>
> Nathan I. Keiter
> |
> Lead Network Applications Programmer
> |
> Benefits Advisory Council Member
> |
> I.D.E.A Council Member
>
> Gettysburg College | Information Technology | DataSystems
>
> Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
>
> Phone: 717.337.6993
>
> <a href="https://www.gettysburg.edu" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNH08Vme5IK4KaYNCVsHJJ1QD5kAhQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNH08Vme5IK4KaYNCVsHJJ1QD5kAhQ&#39;;return true;">https://www.gettysburg.edu
>
>  
>
> From:
> [hidden email] [mailto:dot...@googlegroups.com]
> On Behalf Of [hidden email]
>
> Sent: Wednesday, November 08, 2017 10:27 AM
>
> To: dotCMS User Group
>
> Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade
>
>  
>
>
>
> Hi,
>
>
>
>  
>
>
>
>
> We upgraded a dotCMS instance from 3.7.1 to 4.2.0
>
>
>
>
>  
>
>
>
>
> The upgrade went fine, all SQL scripts etc. have been executed successfully.
>
>
>
>
>  
>
>
>
>
> But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.
>
>
>
>
>
>
> For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.
>
>
>
>
>  
>
>
>
>
> Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.
>
>
>
>
>  
>
>
>
>
> However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.
>
>
>
>
>  
>
>
>
>
> We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.
>
>
>
>
>  
>
>
>
>
> Did anyone experience this before or could anyone tell us how we can solve this?
>
>
>
>
>  
>
>
>
>
> The assets folder etc. is present and all permissions are set correctly.
>
>
>
>
>  
>
>
>
>
> Thank you.
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
> --
>
>
> <a href="http://dotcms.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to
> [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit
> <a href="https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
>
> For more options, visit
> <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.
>
>
>
>
>
> --
>
> <a href="http://dotcms.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to
> [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit
> <a href="https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
>
> For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.
>
>
>
>
>
>
>
>
>
> --
>
> <a href="http://dotcms.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/e9511d978bd24d03939669d61d1c9f5f%40exch13c.ms.gettysburg.edu" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/e9511d978bd24d03939669d61d1c9f5f%40exch13c.ms.gettysburg.edu&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/e9511d978bd24d03939669d61d1c9f5f%40exch13c.ms.gettysburg.edu&#39;;return true;">https://groups.google.com/d/msgid/dotcms/e9511d978bd24d03939669d61d1c9f5f%40exch13c.ms.gettysburg.edu.
>
>
>
> For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.
>
>
>
>
>
> --
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> 3059 Grand Avenue
> Suite 410-B
> Miami FL 33133Main: 305-900-2001 | Direct: 978.294.9429
>
> [hidden email] | <a href="http://dotcms.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">dotcms.com
>
>
>    

Professional with MSSQL database. We are facing 404 errors, but the commit seems to fix a redirect to no license error page?

--
<a href="http://dotcms.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="uQkO-1YqAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dotcms+un...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="uQkO-1YqAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@....
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/cece87bc-7208-4f76-af6b-04c47a5937c9%40googlegroups.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/cece87bc-7208-4f76-af6b-04c47a5937c9%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/cece87bc-7208-4f76-af6b-04c47a5937c9%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/dotcms/cece87bc-7208-4f76-af6b-04c47a5937c9%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.



--



3059 Grand Avenue
Suite 410-B
Miami FL 33133
Main: 
305-900-2001 | Direct: 978.294.9429

<a href="javascript:" target="_blank" gdf-obfuscated-mailto="uQkO-1YqAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">wi...@... | <a href="http://www.dotcms.com/" style="color:rgb(17,85,204)" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.dotcms.com%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFNWs9V2WKwZWrVfr8NIkv4s5e0Dw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.dotcms.com%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFNWs9V2WKwZWrVfr8NIkv4s5e0Dw&#39;;return true;">dotcms.com

<a href="https://twitter.com/dotcms" style="color:rgb(17,85,204)" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Ftwitter.com%2Fdotcms\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFI7UKimTeQqANitfHPRcF_RMkrTw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Ftwitter.com%2Fdotcms\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFI7UKimTeQqANitfHPRcF_RMkrTw&#39;;return true;"> <a href="http://www.linkedin.com/company/dotcms" style="color:rgb(17,85,204)" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.linkedin.com%2Fcompany%2Fdotcms\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG_qDpNIBt3bgBzCOdMhHi9AfMwNA&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.linkedin.com%2Fcompany%2Fdotcms\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG_qDpNIBt3bgBzCOdMhHi9AfMwNA&#39;;return true;"> <a href="https://plus.google.com/+Dotcms" style="color:rgb(17,85,204)" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://plus.google.com/+Dotcms&#39;;return true;" onclick="this.href=&#39;https://plus.google.com/+Dotcms&#39;;return true;"> <a href="https://www.facebook.com/dotCMS" style="color:rgb(17,85,204);font-family:verdana,sans-serif;font-size:x-small" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.facebook.com%2FdotCMS\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNF-Ge1oKMS8PGManhW1ZhuhY8-L9g&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.facebook.com%2FdotCMS\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNF-Ge1oKMS8PGManhW1ZhuhY8-L9g&#39;;return true;">

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/e59262de-c15c-4b20-a56b-9966060d13d1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

Yasin
In reply to this post by wezell1
Hi Will,

That file is present, I think this is a different issue.

Op woensdag 8 november 2017 18:52:04 UTC+1 schreef Will Ezell:
Does that no_license.jsp exist?

On Wed, Nov 8, 2017 at 12:41 PM, <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="uQkO-1YqAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dile...@...> wrote:
Op woensdag 8 november 2017 16:52:17 UTC+1 schreef Will Ezell:
> What license level and db are you using?  We found an issue with that in 4.2.0 that is going to necessitate a hotfix or a move to an upcoming 4.2.1 release if you are being bit by it. 
>
>
> <a href="https://github.com/dotCMS/core/pull/13009/commits/92608458ef77dbe4f42b5f26f1ae89d3e2efe552" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2FdotCMS%2Fcore%2Fpull%2F13009%2Fcommits%2F92608458ef77dbe4f42b5f26f1ae89d3e2efe552\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxLb9q-IpbvorSNIsbFfrTnqj2HQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2FdotCMS%2Fcore%2Fpull%2F13009%2Fcommits%2F92608458ef77dbe4f42b5f26f1ae89d3e2efe552\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxLb9q-IpbvorSNIsbFfrTnqj2HQ&#39;;return true;">https://github.com/dotCMS/core/pull/13009/commits/92608458ef77dbe4f42b5f26f1ae89d3e2efe552
>
>
>
> On Wed, Nov 8, 2017 at 10:33 AM, Nathan Keiter <[hidden email]> wrote:
>
>
>
>
>
>
>
>
>
>
>
> Did you upgrade all your page assets to page contentlets?
>
>  
>
> I can’t remember, but at some point that may have been required as page assets are deprecated.
>
>  
>
> Nathan I. Keiter
> |
> Lead Network Applications Programmer
> |
> Benefits Advisory Council Member
> |
> I.D.E.A Council Member
>
> Gettysburg College | Information Technology | DataSystems
>
> Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
>
> Phone: 717.337.6993
>
> <a href="https://www.gettysburg.edu" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNH08Vme5IK4KaYNCVsHJJ1QD5kAhQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNH08Vme5IK4KaYNCVsHJJ1QD5kAhQ&#39;;return true;">https://www.gettysburg.edu
>
>  
>
> From: [hidden email] [mailto:dot...@googlegroups.com]
> On Behalf Of [hidden email]
>
> Sent: Wednesday, November 08, 2017 10:31 AM
>
> To: dotCMS User Group
>
> Subject: Re: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade
>
>
>
>  
>
>
>
> Hi Nathan,
>
>
>
>
>
> Yes, we full reindexed multiple times already. We even cleared the dotsecure folder (except the licenses) to make this even sure. Restarting dotCMS didn't also make a difference.
>
>
>
>
>  
>
>
>
>
> Thanks.
>
>
>
> Op woensdag 8 november 2017 16:29:24 UTC+1 schreef Nathan Keiter:
>
>
>
>
>
> Did you do a full reindex after upgrading?
>
>  
>
> Sounds like a bad index.
>
>  
>
> Nathan I. Keiter
> |
> Lead Network Applications Programmer
> |
> Benefits Advisory Council Member
> |
> I.D.E.A Council Member
>
> Gettysburg College | Information Technology | DataSystems
>
> Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
>
> Phone: 717.337.6993
>
> <a href="https://www.gettysburg.edu" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNH08Vme5IK4KaYNCVsHJJ1QD5kAhQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNH08Vme5IK4KaYNCVsHJJ1QD5kAhQ&#39;;return true;">https://www.gettysburg.edu
>
>  
>
> From:
> [hidden email] [mailto:dot...@googlegroups.com]
> On Behalf Of [hidden email]
>
> Sent: Wednesday, November 08, 2017 10:27 AM
>
> To: dotCMS User Group
>
> Subject: [dotcms] All page assets returning 404 Page not found error after dotCMS upgrade
>
>  
>
>
>
> Hi,
>
>
>
>  
>
>
>
>
> We upgraded a dotCMS instance from 3.7.1 to 4.2.0
>
>
>
>
>  
>
>
>
>
> The upgrade went fine, all SQL scripts etc. have been executed successfully.
>
>
>
>
>  
>
>
>
>
> But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.
>
>
>
>
>
>
> For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.
>
>
>
>
>  
>
>
>
>
> Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.
>
>
>
>
>  
>
>
>
>
> However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.
>
>
>
>
>  
>
>
>
>
> We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.
>
>
>
>
>  
>
>
>
>
> Did anyone experience this before or could anyone tell us how we can solve this?
>
>
>
>
>  
>
>
>
>
> The assets folder etc. is present and all permissions are set correctly.
>
>
>
>
>  
>
>
>
>
> Thank you.
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
>
>  
>
>
>
> --
>
>
> <a href="http://dotcms.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to
> [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit
> <a href="https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/dotcms/b10d535e-37ec-4136-83d1-8a9bb839aeb4%40googlegroups.com.
>
> For more options, visit
> <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.
>
>
>
>
>
> --
>
> <a href="http://dotcms.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to
> [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit
> <a href="https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/dotcms/87a5a5af-240d-419e-87ec-be545722f420%40googlegroups.com.
>
> For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.
>
>
>
>
>
>
>
>
>
> --
>
> <a href="http://dotcms.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
>
> ---
>
> You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/e9511d978bd24d03939669d61d1c9f5f%40exch13c.ms.gettysburg.edu" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/e9511d978bd24d03939669d61d1c9f5f%40exch13c.ms.gettysburg.edu&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/e9511d978bd24d03939669d61d1c9f5f%40exch13c.ms.gettysburg.edu&#39;;return true;">https://groups.google.com/d/msgid/dotcms/e9511d978bd24d03939669d61d1c9f5f%40exch13c.ms.gettysburg.edu.
>
>
>
> For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.
>
>
>
>
>
> --
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> 3059 Grand Avenue
> Suite 410-B
> Miami FL 33133Main: 305-900-2001 | Direct: 978.294.9429
>
> [hidden email] | <a href="http://dotcms.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">dotcms.com
>
>
>    

Professional with MSSQL database. We are facing 404 errors, but the commit seems to fix a redirect to no license error page?

--
<a href="http://dotcms.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="uQkO-1YqAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dotcms+un...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="uQkO-1YqAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@....
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/cece87bc-7208-4f76-af6b-04c47a5937c9%40googlegroups.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/cece87bc-7208-4f76-af6b-04c47a5937c9%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/cece87bc-7208-4f76-af6b-04c47a5937c9%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/dotcms/cece87bc-7208-4f76-af6b-04c47a5937c9%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.



--



3059 Grand Avenue
Suite 410-B
Miami FL 33133
Main: 
305-900-2001 | Direct: 978.294.9429

<a href="javascript:" target="_blank" gdf-obfuscated-mailto="uQkO-1YqAQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">wi...@... | <a href="http://www.dotcms.com/" style="color:rgb(17,85,204)" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.dotcms.com%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFNWs9V2WKwZWrVfr8NIkv4s5e0Dw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.dotcms.com%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFNWs9V2WKwZWrVfr8NIkv4s5e0Dw&#39;;return true;">dotcms.com

<a href="https://twitter.com/dotcms" style="color:rgb(17,85,204)" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Ftwitter.com%2Fdotcms\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFI7UKimTeQqANitfHPRcF_RMkrTw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Ftwitter.com%2Fdotcms\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFI7UKimTeQqANitfHPRcF_RMkrTw&#39;;return true;"> <a href="http://www.linkedin.com/company/dotcms" style="color:rgb(17,85,204)" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.linkedin.com%2Fcompany%2Fdotcms\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG_qDpNIBt3bgBzCOdMhHi9AfMwNA&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.linkedin.com%2Fcompany%2Fdotcms\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG_qDpNIBt3bgBzCOdMhHi9AfMwNA&#39;;return true;"> <a href="https://plus.google.com/+Dotcms" style="color:rgb(17,85,204)" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://plus.google.com/+Dotcms&#39;;return true;" onclick="this.href=&#39;https://plus.google.com/+Dotcms&#39;;return true;"> <a href="https://www.facebook.com/dotCMS" style="color:rgb(17,85,204);font-family:verdana,sans-serif;font-size:x-small" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.facebook.com%2FdotCMS\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNF-Ge1oKMS8PGManhW1ZhuhY8-L9g&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.facebook.com%2FdotCMS\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNF-Ge1oKMS8PGManhW1ZhuhY8-L9g&#39;;return true;">

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/147c4674-b73c-4633-9bf7-833f7eec4923%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

Yasin
In reply to this post by Yasin
Update:

When upgrading from dotCMS 3.7.1 to 4.1.1 everything works fine.

But when we upgrade from dotCMS 3.7.1 to 4.2.0 we get these 404 errors.

We also tried upgrading first to dotCMS 4.1.1 and afterwards from 4.1.1 to 4.2.0, but that causes also 404 errors.

It seems like there is something not going ok with the 4.2.0 release?

Reindexing is also 10 times slowed in 4.2.0 compared to 4.1.1 (all localhost)

Thanks.

Op woensdag 8 november 2017 16:26:48 UTC+1 schreef [hidden email]:
Hi,

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

The upgrade went fine, all SQL scripts etc. have been executed successfully.

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.

For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

Did anyone experience this before or could anyone tell us how we can solve this?

The assets folder etc. is present and all permissions are set correctly.

Thank you.





--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/df1808db-f82c-4c4b-924e-caf768ac93a7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

wezell1
Please try a trial license to see if that has any effect.  If not, something else is going on - perhaps something with the new vanity urls?  I would reach out to support for a closer look.

On Thu, Nov 9, 2017 at 8:17 AM, <[hidden email]> wrote:
Update:

When upgrading from dotCMS 3.7.1 to 4.1.1 everything works fine.

But when we upgrade from dotCMS 3.7.1 to 4.2.0 we get these 404 errors.

We also tried upgrading first to dotCMS 4.1.1 and afterwards from 4.1.1 to 4.2.0, but that causes also 404 errors.

It seems like there is something not going ok with the 4.2.0 release?

Reindexing is also 10 times slowed in 4.2.0 compared to 4.1.1 (all localhost)

Thanks.

Op woensdag 8 november 2017 16:26:48 UTC+1 schreef [hidden email]:
Hi,

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

The upgrade went fine, all SQL scripts etc. have been executed successfully.

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.

For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

Did anyone experience this before or could anyone tell us how we can solve this?

The assets folder etc. is present and all permissions are set correctly.

Thank you.





--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/df1808db-f82c-4c4b-924e-caf768ac93a7%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



--



3059 Grand Avenue
Suite 410-B
Miami FL 33133
Main: 
305-900-2001 | Direct: 978.294.9429

   

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CAPL0VyGbcTJYTC7igPNF36QX_07ouFsu36qM3b%3DR%2BGxdyEVVrg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: All page assets returning 404 Page not found error after dotCMS upgrade

Yasin
In reply to this post by Yasin
An update on this issue: this seems to be resolved in dotCMS 4.2.1.

Op woensdag 8 november 2017 16:26:48 UTC+1 schreef [hidden email]:
Hi,

We upgraded a dotCMS instance from 3.7.1 to 4.2.0

The upgrade went fine, all SQL scripts etc. have been executed successfully.

But there is one major issue that we couldn't solve. Every page that we try to visit returns a 404 Page not found error.

For example when we try to visit the homepage we get a 404, when we try to visit a different page such as the contact page we also get a 404. It doesn't matter which page we try to visit, every page in the front-end returns a 404.

Even if we login to dotCMS and try to visit the page via the site browser it returns a 404.

However, the dotCMS admin panel works fine, this means we are able to login to dotCMS and we can view our content, structures, portlets etc. But visiting Page Assets doesn't work.

We checked the dotCMS and wrapper logs, and no exceptions or errors are thrown. So we are not getting feedback either.

Did anyone experience this before or could anyone tell us how we can solve this?

The assets folder etc. is present and all permissions are set correctly.

Thank you.





--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/3ba42bb7-3cfb-4bf9-b282-54a64a231468%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.