Building dotcms from svn

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Building dotcms from svn

lordfinesse6
Hi,
I'm trying to build DotCMS from source code (using Eclipse).
I've created an empty database, run an "ant deploy" and started the
application (following this article
<http://www.dotcms.org/documentation/SettingUpADevelopmentEnvironmentInE\
clipse> ).
Nevertheless, when I start the application, the only table created is
"db_version": after that, i get a lot of SQLException:

[23/03/10 05:30:40:040 GMT]  WARN util.JDBCExceptionReporter: SQL Error:
0, SQLState: 42P01
[23/03/10 05:30:40:040 GMT] ERROR util.JDBCExceptionReporter: ERROR: la
relazione "release_" non esiste
[23/03/10 05:30:40:040 GMT]  WARN util.JDBCExceptionReporter: SQL Error:
0, SQLState: 42P01
[23/03/10 05:30:40:040 GMT] ERROR util.JDBCExceptionReporter: ERROR: la
relazione "release_" non esiste
[23/03/10 05:30:40:040 GMT] ERROR servlet.MainServlet:
com.liferay.portal.struts.ActionException:
com.liferay.portal.SystemException:
net.sf.hibernate.exception.SQLGrammarException: could not load:
[com.liferay.portal.ejb.ReleaseHBM#1]
com.liferay.portal.struts.ActionException:
com.liferay.portal.struts.ActionException:
com.liferay.portal.SystemException:
net.sf.hibernate.exception.SQLGrammarException: could not load:
[com.liferay.portal.ejb.ReleaseHBM#1]

and so on...
Am I missing something?

Thanks in advance
Giulio


Reply | Threaded
Open this post in threaded view
|

Re: Building dotcms from svn

Jason Tesser-2
from eclipse you don't want to run ant deploy. You want eclipse to build for
you. you only need to run the ant task "buildsql" or 'buildmXsql'

http://www.dotcms.org/documentation/SettingUpADevelopmentEnvironmentInEclipse

Thanks,
Jason Tesser
dotCMS Lead Development Manager
1-305-858-1422


On Tue, Mar 23, 2010 at 1:41 PM, lordfinesse6 <[hidden email]> wrote:

>
>
> Hi,
> I'm trying to build DotCMS from source code (using Eclipse).
> I've created an empty database, run an "ant deploy" and started the
> application (following this article<http://www.dotcms.org/documentation/SettingUpADevelopmentEnvironmentInEclipse>
> ).
> Nevertheless, when I start the application, the only table created is
> "db_version": after that, i get a lot of SQLException:
>
> [23/03/10 05:30:40:040 GMT]  WARN util.JDBCExceptionReporter: SQL Error: 0,
> SQLState: 42P01
> [23/03/10 05:30:40:040 GMT] ERROR util.JDBCExceptionReporter: ERROR: la
> relazione "release_" non esiste
> [23/03/10 05:30:40:040 GMT]  WARN util.JDBCExceptionReporter: SQL Error: 0,
> SQLState: 42P01
> [23/03/10 05:30:40:040 GMT] ERROR util.JDBCExceptionReporter: ERROR: la
> relazione "release_" non esiste
> [23/03/10 05:30:40:040 GMT] ERROR servlet.MainServlet:
> com.liferay.portal.struts.ActionException:
> com.liferay.portal.SystemException:
> net.sf.hibernate.exception.SQLGrammarException: could not load:
> [com.liferay.portal.ejb.ReleaseHBM#1]
> com.liferay.portal.struts.ActionException:
> com.liferay.portal.struts.ActionException:
> com.liferay.portal.SystemException:
> net.sf.hibernate.exception.SQLGrammarException: could not load:
> [com.liferay.portal.ejb.ReleaseHBM#1]
>
> and so on...
> Am I missing something?
>
> Thanks in advance
> Giulio
>
>  
>
Reply | Threaded
Open this post in threaded view
|

Re: Building dotcms from svn

wezell-2
Administrator
There is an issue in the svn trunk that is preventing dotCMS from building
its database.  If you revert these two files, it should load for you.

svn update -r 19794 src/com/liferay/portal/servlet/MainServlet.java
svn update -r 20984 src/com/dotmarketing/startup/StartupTasksExecutor.java


Will

----
Will Ezell
www.dotcms.org
phone: 305.858.1422 ext. 286
direct: 978.296.4239
skype: wezell1




On Tue, Mar 23, 2010 at 2:27 PM, Jason Tesser <[hidden email]> wrote:

>
>
> from eclipse you don't want to run ant deploy. You want eclipse to build
> for you. you only need to run the ant task "buildsql" or 'buildmXsql'
>
>
> http://www.dotcms.org/documentation/SettingUpADevelopmentEnvironmentInEclipse
>
> Thanks,
> Jason Tesser
> dotCMS Lead Development Manager
> 1-305-858-1422
>
>
>
> On Tue, Mar 23, 2010 at 1:41 PM, lordfinesse6 <[hidden email]> wrote:
>
>>
>>
>> Hi,
>> I'm trying to build DotCMS from source code (using Eclipse).
>> I've created an empty database, run an "ant deploy" and started the
>> application (following this article<http://www.dotcms.org/documentation/SettingUpADevelopmentEnvironmentInEclipse>
>> ).
>> Nevertheless, when I start the application, the only table created is
>> "db_version": after that, i get a lot of SQLException:
>>
>> [23/03/10 05:30:40:040 GMT]  WARN util.JDBCExceptionReporter: SQL Error:
>> 0, SQLState: 42P01
>> [23/03/10 05:30:40:040 GMT] ERROR util.JDBCExceptionReporter: ERROR: la
>> relazione "release_" non esiste
>> [23/03/10 05:30:40:040 GMT]  WARN util.JDBCExceptionReporter: SQL Error:
>> 0, SQLState: 42P01
>> [23/03/10 05:30:40:040 GMT] ERROR util.JDBCExceptionReporter: ERROR: la
>> relazione "release_" non esiste
>> [23/03/10 05:30:40:040 GMT] ERROR servlet.MainServlet:
>> com.liferay.portal.struts.ActionException:
>> com.liferay.portal.SystemException:
>> net.sf.hibernate.exception.SQLGrammarException: could not load:
>> [com.liferay.portal.ejb.ReleaseHBM#1]
>> com.liferay.portal.struts.ActionException:
>> com.liferay.portal.struts.ActionException:
>> com.liferay.portal.SystemException:
>> net.sf.hibernate.exception.SQLGrammarException: could not load:
>> [com.liferay.portal.ejb.ReleaseHBM#1]
>>
>> and so on...
>> Am I missing something?
>>
>> Thanks in advance
>> Giulio
>>
>>
>
>
>
>
>