Can't use more than 1 field in urlmap

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't use more than 1 field in urlmap

aDNers
Hello hello,

I experience a wierd thing with the urlmaps. 

The url map: /guides/{articleId}/{articleId} 
gives the following expected generated urlTitle:

/guides/{urlTitle}/{articleId} 
instead gives the following urlTitle:

Not sure why I can't use more than one "field variable" in the urlmap. 

Anyone experienced this before?

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/1defe996-6a36-40fb-b68a-d6be1010adc0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

RE: Can't use more than 1 field in urlmap

Nathan Keiter

I think it’s more that you are using the same field twice, rather than two fields. Perhaps in the underlying code it’s doing a replace instead of a replaceAll?

 

I think using a unique identifier twice to show content is not the intended function. Why do you need to send two unique ids?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of aDNers
Sent: Thursday, November 02, 2017 8:06 AM
To: dotCMS User Group
Subject: [dotcms] Can't use more than 1 field in urlmap

 

Hello hello,

 

I experience a wierd thing with the urlmaps. 

 

The url map: /guides/{articleId}/{articleId} 

gives the following expected generated urlTitle:

 

/guides/{urlTitle}/{articleId} 

instead gives the following urlTitle:

 

Not sure why I can't use more than one "field variable" in the urlmap. 

 

Anyone experienced this before?

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/1defe996-6a36-40fb-b68a-d6be1010adc0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/25ee8baa46a748e9a380378d4e2e0871%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Can't use more than 1 field in urlmap

aDNers
Hi,

In my usecase I don't want to use the same field twice, I want to use 2 separate fields. But when I use 2 different fields only the first one is rendered. My original example just showed that using the same field twice rendered the generated fieldcontent twice. (The reason for me wanting to use 2 different fields is that in our migration from our old CMS I have a path saved in a field (something like: cars/sportcar) and I want to build the urlmap as: /guides/{urlPath}/{urlTitle} but now only the urlPath is rendered.) Sorry for not being totally clear about the issue from the beginning. 

In the screenshots below I did the same operation on the default News-type, for some reasons the {byline} is not being generated. If I witch order of {urlTitle} and {byline} the urlTitle is not generated. 

As stated in the example to the left, you should be able to use two fields, in that case - {productType} and {urlTitle} - however it doesn't seem to work for me.. 



Den torsdag 2 november 2017 kl. 13:46:06 UTC+1 skrev Nathan Keiter:

I think it’s more that you are using the same field twice, rather than two fields. Perhaps in the underlying code it’s doing a replace instead of a replaceAll?

 

I think using a unique identifier twice to show content is not the intended function. Why do you need to send two unique ids?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

<a href="https://www.gettysburg.edu/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.gettysburg.edu%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG7XlfToBr_IA0adrY4nu9tVtLS_w&#39;;return true;">https://www.gettysburg.edu

 

From: <a href="javascript:" target="_blank" gdf-obfuscated-mailto="d_JMDC6IAwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@... [mailto:<a href="javascript:" target="_blank" gdf-obfuscated-mailto="d_JMDC6IAwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@googlegroups.com] On Behalf Of aDNers
Sent: Thursday, November 02, 2017 8:06 AM
To: dotCMS User Group
Subject: [dotcms] Can't use more than 1 field in urlmap

 

Hello hello,

 

I experience a wierd thing with the urlmaps. 

 

The url map: /guides/{articleId}/{articleId} 

gives the following expected generated urlTitle:

<a href="http://127.0.0.1:8080/dotAdmin/#/c/site-browser?url=%2Ftester%2F50239%2F50239%2F" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F127.0.0.1%3A8080%2FdotAdmin%2F%23%2Fc%2Fsite-browser%3Furl%3D%252Ftester%252F50239%252F50239%252F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNED_opg4pyPeQOsSEqWSBX7z1pIjw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F127.0.0.1%3A8080%2FdotAdmin%2F%23%2Fc%2Fsite-browser%3Furl%3D%252Ftester%252F50239%252F50239%252F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNED_opg4pyPeQOsSEqWSBX7z1pIjw&#39;;return true;">/guides/50239/50239/

 

/guides/{urlTitle}/{articleId} 

instead gives the following urlTitle:

<a href="http://127.0.0.1:8080/dotAdmin/#/c/site-browser?url=%2Ftester%2Fguide-10-friggebodar%2F%7BektronId%7D%2F" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F127.0.0.1%3A8080%2FdotAdmin%2F%23%2Fc%2Fsite-browser%3Furl%3D%252Ftester%252Fguide-10-friggebodar%252F%257BektronId%257D%252F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGxzRQrIUJ5RpdHCFid5VetG_C1XA&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F127.0.0.1%3A8080%2FdotAdmin%2F%23%2Fc%2Fsite-browser%3Furl%3D%252Ftester%252Fguide-10-friggebodar%252F%257BektronId%257D%252F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGxzRQrIUJ5RpdHCFid5VetG_C1XA&#39;;return true;">/guides/guide-10-scissors/{articleId}/

 

Not sure why I can't use more than one "field variable" in the urlmap. 

 

Anyone experienced this before?

--
<a href="http://dotcms.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="d_JMDC6IAwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dotcms+un...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="d_JMDC6IAwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@....
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/1defe996-6a36-40fb-b68a-d6be1010adc0%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/1defe996-6a36-40fb-b68a-d6be1010adc0%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/1defe996-6a36-40fb-b68a-d6be1010adc0%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;"> https://groups.google.com/d/msgid/dotcms/1defe996-6a36-40fb-b68a-d6be1010adc0%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/6b9764cd-c8e8-43f1-93a3-a58a3bc4f529%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Can't use more than 1 field in urlmap

Jason Tesser
Can you also send a screeshot of your Content Type Fields 

On Thu, Nov 2, 2017 at 9:13 AM aDNers <[hidden email]> wrote:
Hi,

In my usecase I don't want to use the same field twice, I want to use 2 separate fields. But when I use 2 different fields only the first one is rendered. My original example just showed that using the same field twice rendered the generated fieldcontent twice. (The reason for me wanting to use 2 different fields is that in our migration from our old CMS I have a path saved in a field (something like: cars/sportcar) and I want to build the urlmap as: /guides/{urlPath}/{urlTitle} but now only the urlPath is rendered.) Sorry for not being totally clear about the issue from the beginning. 

In the screenshots below I did the same operation on the default News-type, for some reasons the {byline} is not being generated. If I witch order of {urlTitle} and {byline} the urlTitle is not generated. 

As stated in the example to the left, you should be able to use two fields, in that case - {productType} and {urlTitle} - however it doesn't seem to work for me.. 



Den torsdag 2 november 2017 kl. 13:46:06 UTC+1 skrev Nathan Keiter:

I think it’s more that you are using the same field twice, rather than two fields. Perhaps in the underlying code it’s doing a replace instead of a replaceAll?

 

I think using a unique identifier twice to show content is not the intended function. Why do you need to send two unique ids?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: <a href="tel:(717)%20337-6993" value="+17173376993" target="_blank">717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of aDNers


Sent: Thursday, November 02, 2017 8:06 AM
To: dotCMS User Group
Subject: [dotcms] Can't use more than 1 field in urlmap

 

Hello hello,

 

I experience a wierd thing with the urlmaps. 

 

The url map: /guides/{articleId}/{articleId} 

gives the following expected generated urlTitle:

 

/guides/{urlTitle}/{articleId} 

instead gives the following urlTitle:

 

Not sure why I can't use more than one "field variable" in the urlmap. 

 

Anyone experienced this before?

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.

To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/6b9764cd-c8e8-43f1-93a3-a58a3bc4f529%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
--



3059 Grand Avenue
Suite 410-B
Miami FL 33133
Main: 
305-900-2001 | Direct: 978.294.9429

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CAKKUxWfKmKvUpOFGBS87fi76RW32j4U%2Bft_TRJB5104hLJDrJg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

RE: Can't use more than 1 field in urlmap

Nathan Keiter
In reply to this post by aDNers

Perhaps a bug then… what version you are on would probably be helpful to someone who can help.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of aDNers
Sent: Thursday, November 02, 2017 9:13 AM
To: dotCMS User Group
Subject: Re: [dotcms] Can't use more than 1 field in urlmap

 

Hi,

 

In my usecase I don't want to use the same field twice, I want to use 2 separate fields. But when I use 2 different fields only the first one is rendered. My original example just showed that using the same field twice rendered the generated fieldcontent twice. (The reason for me wanting to use 2 different fields is that in our migration from our old CMS I have a path saved in a field (something like: cars/sportcar) and I want to build the urlmap as: /guides/{urlPath}/{urlTitle} but now only the urlPath is rendered.) Sorry for not being totally clear about the issue from the beginning. 

 

In the screenshots below I did the same operation on the default News-type, for some reasons the {byline} is not being generated. If I witch order of {urlTitle} and {byline} the urlTitle is not generated. 

 

As stated in the example to the left, you should be able to use two fields, in that case - {productType} and {urlTitle} - however it doesn't seem to work for me.. 

 



Den torsdag 2 november 2017 kl. 13:46:06 UTC+1 skrev Nathan Keiter:

I think it’s more that you are using the same field twice, rather than two fields. Perhaps in the underlying code it’s doing a replace instead of a replaceAll?

 

I think using a unique identifier twice to show content is not the intended function. Why do you need to send two unique ids?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: <a href="javascript:" target="_blank">dot...@... [mailto:<a href="javascript:" target="_blank">dot...@...] On Behalf Of aDNers
Sent: Thursday, November 02, 2017 8:06 AM
To: dotCMS User Group
Subject: [dotcms] Can't use more than 1 field in urlmap

 

Hello hello,

 

I experience a wierd thing with the urlmaps. 

 

The url map: /guides/{articleId}/{articleId} 

gives the following expected generated urlTitle:

 

/guides/{urlTitle}/{articleId} 

instead gives the following urlTitle:

 

Not sure why I can't use more than one "field variable" in the urlmap. 

 

Anyone experienced this before?

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank">dotcms+un...@....
To post to this group, send email to <a href="javascript:" target="_blank">dot...@....
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/1defe996-6a36-40fb-b68a-d6be1010adc0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/6b9764cd-c8e8-43f1-93a3-a58a3bc4f529%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/b036af51136b4347920704899d99fb04%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Can't use more than 1 field in urlmap

fishsmith
Administrator
In reply to this post by aDNers
make sure on your Byline field in the content type you checked index on that field.

On Thu, Nov 2, 2017 at 9:13 AM aDNers <[hidden email]> wrote:
Hi,

In my usecase I don't want to use the same field twice, I want to use 2 separate fields. But when I use 2 different fields only the first one is rendered. My original example just showed that using the same field twice rendered the generated fieldcontent twice. (The reason for me wanting to use 2 different fields is that in our migration from our old CMS I have a path saved in a field (something like: cars/sportcar) and I want to build the urlmap as: /guides/{urlPath}/{urlTitle} but now only the urlPath is rendered.) Sorry for not being totally clear about the issue from the beginning. 

In the screenshots below I did the same operation on the default News-type, for some reasons the {byline} is not being generated. If I witch order of {urlTitle} and {byline} the urlTitle is not generated. 

As stated in the example to the left, you should be able to use two fields, in that case - {productType} and {urlTitle} - however it doesn't seem to work for me.. 



Den torsdag 2 november 2017 kl. 13:46:06 UTC+1 skrev Nathan Keiter:

I think it’s more that you are using the same field twice, rather than two fields. Perhaps in the underlying code it’s doing a replace instead of a replaceAll?

 

I think using a unique identifier twice to show content is not the intended function. Why do you need to send two unique ids?

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: <a href="tel:(717)%20337-6993" value="+17173376993" target="_blank">717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of aDNers


Sent: Thursday, November 02, 2017 8:06 AM
To: dotCMS User Group
Subject: [dotcms] Can't use more than 1 field in urlmap

 

Hello hello,

 

I experience a wierd thing with the urlmaps. 

 

The url map: /guides/{articleId}/{articleId} 

gives the following expected generated urlTitle:

 

/guides/{urlTitle}/{articleId} 

instead gives the following urlTitle:

 

Not sure why I can't use more than one "field variable" in the urlmap. 

 

Anyone experienced this before?

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.

To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/6b9764cd-c8e8-43f1-93a3-a58a3bc4f529%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CAJ-D54dOwoJVezRmb2AnYp7dMnYwVH_YSb%2BTqWDHocKtdB%3DQww%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Can't use more than 1 field in urlmap

wezell1
In reply to this post by Nathan Keiter
That looks like an issue with the javascript that tries to auto generate the urlmap rather than the urlmap itself.  It looks like you could edit the javascript in the custom field and fix the issue.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CAPL0VyE0%3D4drRkRxoJ0zT7jU8gdjND7t7hnQ3NKh74n_3-z2Sw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Can't use more than 1 field in urlmap

aDNers
Hi,

Thanks for all answers. I will check if I can fix the javascript in order to solve my issue. I use the javascript from /application/vtl/custom-fields/url-title.vtl
Jason: you could check the default media type "news" from the dotcms starter page. I have not made any changes to it, and it seems as the byline was indeed indexed, however ... not sure I want to say this, I am currently using version 4.3 nightly build ;-D (maybe I should have tested this on a released version instead before asking in the forum.)

Also, we might have thought of a workaround for this using regexp redirects with vanityurls instead..

If I am the only one experience this, it must be something local but thanks for all suggestions.


Den torsdag 2 november 2017 kl. 14:23:45 UTC+1 skrev Will Ezell:
That looks like an issue with the javascript that tries to auto generate the urlmap rather than the urlmap itself.  It looks like you could edit the javascript in the custom field and fix the issue.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/d8d38b7b-3d65-483d-8ed6-e4fa650c75c7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Can't use more than 1 field in urlmap

Jason Tesser-2
So yea for sure then edit this VTL #dotParse('/application/vtl/custom-fields/url-title.vtl')
That is the custom field. It is really an example for displaying the URL title. 
It doesn't effect the URL Map from resolving which is important to mention. It is just a handy display of what it will resolve at nothing to do with functionality FWIW 

On Thu, Nov 2, 2017 at 10:13 AM aDNers <[hidden email]> wrote:
Hi,

Thanks for all answers. I will check if I can fix the javascript in order to solve my issue. I use the javascript from /application/vtl/custom-fields/url-title.vtl
Jason: you could check the default media type "news" from the dotcms starter page. I have not made any changes to it, and it seems as the byline was indeed indexed, however ... not sure I want to say this, I am currently using version 4.3 nightly build ;-D (maybe I should have tested this on a released version instead before asking in the forum.)

Also, we might have thought of a workaround for this using regexp redirects with vanityurls instead..

If I am the only one experience this, it must be something local but thanks for all suggestions.


Den torsdag 2 november 2017 kl. 14:23:45 UTC+1 skrev Will Ezell:
That looks like an issue with the javascript that tries to auto generate the urlmap rather than the urlmap itself.  It looks like you could edit the javascript in the custom field and fix the issue.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/d8d38b7b-3d65-483d-8ed6-e4fa650c75c7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CALDe1GN9CxZo7NMvxQ2RXEYqS3Ekzoc7ZcmnVAzwxP-k6CDO4w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Can't use more than 1 field in urlmap

bodenanders
Just thought I should post how we updated the urltitle.vtl incase anyone wonders. The default vtl
#dotParse('/application/vtl/custom-fields/url-title.vtl')

has a section at the bottom:
for(i=0;i<matches.length;i++){
var val = dojo.byId(matches[0]).value;
console.log(matches[0]);
console.log(val);
urlMap  =urlMap.replace("{"+matches[0]+"}", val);
}

which clearly takes the first index position [0], so just changing [0] to [i] solved a lot.

Thanks,
Anders


Den torsdag 2 november 2017 kl. 15:28:31 UTC+1 skrev LORDs_diakonos:
So yea for sure then edit this VTL #dotParse('/application/vtl/custom-fields/url-title.vtl')
That is the custom field. It is really an example for displaying the URL title. 
It doesn't effect the URL Map from resolving which is important to mention. It is just a handy display of what it will resolve at nothing to do with functionality FWIW 

On Thu, Nov 2, 2017 at 10:13 AM aDNers <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="bdNToMSNAwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">and...@...> wrote:
Hi,

Thanks for all answers. I will check if I can fix the javascript in order to solve my issue. I use the javascript from /application/vtl/custom-fields/url-title.vtl
Jason: you could check the default media type "news" from the dotcms starter page. I have not made any changes to it, and it seems as the byline was indeed indexed, however ... not sure I want to say this, I am currently using version 4.3 nightly build ;-D (maybe I should have tested this on a released version instead before asking in the forum.)

Also, we might have thought of a workaround for this using regexp redirects with vanityurls instead..

If I am the only one experience this, it must be something local but thanks for all suggestions.


Den torsdag 2 november 2017 kl. 14:23:45 UTC+1 skrev Will Ezell:
That looks like an issue with the javascript that tries to auto generate the urlmap rather than the urlmap itself.  It looks like you could edit the javascript in the custom field and fix the issue.

--
<a href="http://dotcms.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="bdNToMSNAwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dotcms+un...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="bdNToMSNAwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@....
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/d8d38b7b-3d65-483d-8ed6-e4fa650c75c7%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/d8d38b7b-3d65-483d-8ed6-e4fa650c75c7%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/d8d38b7b-3d65-483d-8ed6-e4fa650c75c7%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/dotcms/d8d38b7b-3d65-483d-8ed6-e4fa650c75c7%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/42185bc4-2a74-4e11-91a1-3c667ae395e8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.