Index blocked for some reason

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Index blocked for some reason

Xander
Hi all,

I have a very strange issue in one of our environments. When running a reindex the reindex is blocked on 0% (I can see records in dist_reindex_journal), but when I copy the database to my local pc and run a reindex then it indexes without issues. What could be causing this reindexing problem? There are no errors in the logs...

It's a dotCMS 3.7.1 with an Oracle DB.

Kind regards,

Xander

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/7f67f67b-f4d4-4c60-8c32-697dc0fc1b3e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Index blocked for some reason

wezell1
So, very roughly, it seems like you are missing the stored proc that builds the list of records to index. I would make sure that the 1) the stored procedure exists on the remote environ (and all of the stored procedures) and 2) that the db user has the proper permissions on it.  I know my nomenclature is off for Oracle but the ideas are the same.

On Wed, Aug 23, 2017 at 11:00 AM, Xander Steinmann <[hidden email]> wrote:
Hi all,

I have a very strange issue in one of our environments. When running a reindex the reindex is blocked on 0% (I can see records in dist_reindex_journal), but when I copy the database to my local pc and run a reindex then it indexes without issues. What could be causing this reindexing problem? There are no errors in the logs...

It's a dotCMS 3.7.1 with an Oracle DB.

Kind regards,

Xander

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/7f67f67b-f4d4-4c60-8c32-697dc0fc1b3e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--






3059 Grand Avenue
Suite 410-B
Miami FL 33133
Main: 
305-900-2001 | Direct: 978.294.9429

   

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CAPL0VyF3rrrpVKjyi61evVFiNxEJvDYDbmrB7JRw%2BPm33CBxcA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Index blocked for some reason

Xander
Thank you Will, I will investigate the stored procedures and user permissions.

Kind regards,

Xander

Op woensdag 23 augustus 2017 17:12:44 UTC+2 schreef Will Ezell:
So, very roughly, it seems like you are missing the stored proc that builds the list of records to index. I would make sure that the 1) the stored procedure exists on the remote environ (and all of the stored procedures) and 2) that the db user has the proper permissions on it.  I know my nomenclature is off for Oracle but the ideas are the same.

On Wed, Aug 23, 2017 at 11:00 AM, Xander Steinmann <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="KCniUeRSDQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">xan...@...> wrote:
Hi all,

I have a very strange issue in one of our environments. When running a reindex the reindex is blocked on 0% (I can see records in dist_reindex_journal), but when I copy the database to my local pc and run a reindex then it indexes without issues. What could be causing this reindexing problem? There are no errors in the logs...

It's a dotCMS 3.7.1 with an Oracle DB.

Kind regards,

Xander

--
<a href="http://dotcms.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fdotcms.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFT4ej1MQxQ2vu3iAUqYQgS59efw&#39;;return true;">http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="KCniUeRSDQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dotcms+un...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="KCniUeRSDQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">dot...@....
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/dotcms/7f67f67b-f4d4-4c60-8c32-697dc0fc1b3e%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/dotcms/7f67f67b-f4d4-4c60-8c32-697dc0fc1b3e%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/dotcms/7f67f67b-f4d4-4c60-8c32-697dc0fc1b3e%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/dotcms/7f67f67b-f4d4-4c60-8c32-697dc0fc1b3e%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.



--






3059 Grand Avenue
Suite 410-B
Miami FL 33133
Main: 
305-900-2001 | Direct: 978.294.9429

<a href="javascript:" target="_blank" gdf-obfuscated-mailto="KCniUeRSDQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">wi...@... | <a href="http://www.dotcms.com/" style="color:rgb(17,85,204)" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.dotcms.com%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFNWs9V2WKwZWrVfr8NIkv4s5e0Dw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.dotcms.com%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFNWs9V2WKwZWrVfr8NIkv4s5e0Dw&#39;;return true;">dotcms.com

<a href="https://twitter.com/dotcms" style="color:rgb(17,85,204)" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Ftwitter.com%2Fdotcms\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFI7UKimTeQqANitfHPRcF_RMkrTw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Ftwitter.com%2Fdotcms\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFI7UKimTeQqANitfHPRcF_RMkrTw&#39;;return true;"> <a href="http://www.linkedin.com/company/dotcms" style="color:rgb(17,85,204)" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.linkedin.com%2Fcompany%2Fdotcms\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG_qDpNIBt3bgBzCOdMhHi9AfMwNA&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.linkedin.com%2Fcompany%2Fdotcms\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG_qDpNIBt3bgBzCOdMhHi9AfMwNA&#39;;return true;"> <a href="https://plus.google.com/+Dotcms" style="color:rgb(17,85,204)" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://plus.google.com/+Dotcms&#39;;return true;" onclick="this.href=&#39;https://plus.google.com/+Dotcms&#39;;return true;"> <a href="https://www.facebook.com/dotCMS" style="color:rgb(17,85,204);font-family:verdana,sans-serif;font-size:x-small" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.facebook.com%2FdotCMS\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNF-Ge1oKMS8PGManhW1ZhuhY8-L9g&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.facebook.com%2FdotCMS\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNF-Ge1oKMS8PGManhW1ZhuhY8-L9g&#39;;return true;">

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/06149507-e756-4a96-ae13-0845f674696e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

RE: Index blocked for some reason

Nathan Keiter

Also try clearing the Indices cache and/or restarting the bad node (clears memory cache for sure.)

 

We just recovered from a recent index issue ourselves.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Xander Steinmann
Sent: Wednesday, August 23, 2017 11:18 AM
To: dotCMS User Group
Subject: Re: [dotcms] Index blocked for some reason

 

Thank you Will, I will investigate the stored procedures and user permissions.

 

Kind regards,

 

Xander

Op woensdag 23 augustus 2017 17:12:44 UTC+2 schreef Will Ezell:

So, very roughly, it seems like you are missing the stored proc that builds the list of records to index. I would make sure that the 1) the stored procedure exists on the remote environ (and all of the stored procedures) and 2) that the db user has the proper permissions on it.  I know my nomenclature is off for Oracle but the ideas are the same.

 

On Wed, Aug 23, 2017 at 11:00 AM, Xander Steinmann <<a href="javascript:" target="_blank">xan...@...> wrote:

Hi all,

 

I have a very strange issue in one of our environments. When running a reindex the reindex is blocked on 0% (I can see records in dist_reindex_journal), but when I copy the database to my local pc and run a reindex then it indexes without issues. What could be causing this reindexing problem? There are no errors in the logs...

 

It's a dotCMS 3.7.1 with an Oracle DB.

 

Kind regards,

 

Xander

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank">dotcms+un...@....
To post to this group, send email to <a href="javascript:" target="_blank">dot...@....
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/7f67f67b-f4d4-4c60-8c32-697dc0fc1b3e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



 

--

 

 

 

 

 

 

3059 Grand Avenue

Suite 410-B

Miami FL 33133

Main: 305-900-2001 | Direct: 978.294.9429


<a href="javascript:" target="_blank">wi...@... | dotcms.com

 

   

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/06149507-e756-4a96-ae13-0845f674696e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/0f638679b57c430fb172789d8df65e59%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Index blocked for some reason

Xander
Hi Will and Nathan,

I was able to fix the issue for my local db when I added two missing types: reindex_record and reindex_record_list. I'm not sure why they were missing. Is it possible that the database user does not have enough permissions to create them? And are they created on the fly?
After adding them and restarting dotCMS (thanks Nathan :)) the reindex worked fine.

Kind regards,

Xander

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/35e74b21-7333-42b3-8eed-174f53f5c4fa%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Index blocked for some reason

wezell1
Great Xander - good to hear.  And yes, probably the user did not have enough permissions to create them.  They are only created on initial startup and data load.

On Thu, Aug 24, 2017 at 6:57 AM, Xander Steinmann <[hidden email]> wrote:
Hi Will and Nathan,

I was able to fix the issue for my local db when I added two missing types: reindex_record and reindex_record_list. I'm not sure why they were missing. Is it possible that the database user does not have enough permissions to create them? And are they created on the fly?
After adding them and restarting dotCMS (thanks Nathan :)) the reindex worked fine.

Kind regards,

Xander

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/35e74b21-7333-42b3-8eed-174f53f5c4fa%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



--






3059 Grand Avenue
Suite 410-B
Miami FL 33133
Main: 
305-900-2001 | Direct: 978.294.9429

   

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CAPL0VyH9Gbq2uR%2BpY9Qmw%2Bs8_UT79h5E2CQ9zz4J3Ljj%2B6321g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Index blocked for some reason

Xander
Hi Will,

After a lot of back-and-forth a DBA investigated the load_records_to_index and told me that it causes an exception: ORA-06502: PL/SQL: numeric or value error: character to number conversion error.
It's in this line of the load_records_to_index: ;data_ret(data_ret.Last) := reindex_record(dj.id,dj.inode_to_index,dj.ident_to_index,dj.priority,dj.dist_action)

Can this be because of some bad record in the dist_reindex_journal or one of the types it uses? Or maybe the load_records_to_index was not updated after an upgrade?

Kind regards,

Xander 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/ad5c3742-2408-4680-b7d2-0430941b5f98%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Index blocked for some reason

Jason Tesser-2

Most likely the db restore is missing something imo


On Tue, Sep 5, 2017, 2:29 AM Xander Steinmann <[hidden email]> wrote:
Hi Will,

After a lot of back-and-forth a DBA investigated the load_records_to_index and told me that it causes an exception: ORA-06502: PL/SQL: numeric or value error: character to number conversion error.
It's in this line of the load_records_to_index: ;data_ret(data_ret.Last) := reindex_record(dj.id,dj.inode_to_index,dj.ident_to_index,dj.priority,dj.dist_action)

Can this be because of some bad record in the dist_reindex_journal or one of the types it uses? Or maybe the load_records_to_index was not updated after an upgrade?

Kind regards,

Xander 

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/ad5c3742-2408-4680-b7d2-0430941b5f98%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CALDe1GPCGrNpBHnwx1J3sTNbfvd6KNTFvpm0j52z7M-BJJtLOw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Index blocked for some reason

Xander
Is there some class we can override to add logging of some sort? There must be an exception somewhere that is not logged...

Kind regards,

Xander

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/0f7adef1-ce2d-473e-81fa-9d1084b0c957%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

RE: Index blocked for some reason

Nathan Keiter

In our experience, restarting dotCMS usually solves this kind of “errorless” index issue.

 

Our theory is something in the JVM memory relating to index cache gets corrupted occasionally, interfering with the index process. Oddly, dumping the caches won’t resolve it, only a fresh JVM instance.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: 717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Xander Steinmann
Sent: Wednesday, September 06, 2017 9:00 AM
To: dotCMS User Group
Subject: Re: [dotcms] Index blocked for some reason

 

Is there some class we can override to add logging of some sort? There must be an exception somewhere that is not logged...

 

Kind regards,

 

Xander

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/0f7adef1-ce2d-473e-81fa-9d1084b0c957%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/643894bbae074d29890ca3527352f994%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Index blocked for some reason

Jason Tesser-2
Well you have the error at the DB.  It is something with the DB.  

The class that calls that function is ESDistributedJournalFactoryImpl 

But I am pretty sure this is an issue with the restore of the DB somehow. 

On Wed, Sep 6, 2017 at 9:06 AM Nathan Keiter <[hidden email]> wrote:

In our experience, restarting dotCMS usually solves this kind of “errorless” index issue.

 

Our theory is something in the JVM memory relating to index cache gets corrupted occasionally, interfering with the index process. Oddly, dumping the caches won’t resolve it, only a fresh JVM instance.

 

Nathan I. Keiter | Lead Network Applications Programmer | Benefits Advisory Council Member | I.D.E.A Council Member
Gettysburg College | Information Technology | DataSystems
Campus Box 2453 | 300 North Washington Street | Gettysburg, PA 17325
Phone: <a href="tel:(717)%20337-6993" value="+17173376993" target="_blank">717.337.6993

https://www.gettysburg.edu

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Xander Steinmann
Sent: Wednesday, September 06, 2017 9:00 AM


To: dotCMS User Group
Subject: Re: [dotcms] Index blocked for some reason

 

Is there some class we can override to add logging of some sort? There must be an exception somewhere that is not logged...

 

Kind regards,

 

Xander

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/0f7adef1-ce2d-473e-81fa-9d1084b0c957%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/643894bbae074d29890ca3527352f994%40exch13c.ms.gettysburg.edu.
For more options, visit https://groups.google.com/d/optout.

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CALDe1GOhRkBKSdWs3o1NGra6U7RBasB_Otan6Wboz9WgLQftiQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Index blocked for some reason

Xander
Hi Jason,

You were right. After adding a lot of logging in the ESDistributedJournalFactoryImpl we noticed that an exception wasn't logged, which was a "character to number conversion error" in LOAD_RECORDS_TO_INDEX line 14. After looking into that we noticed that the order of the parameters in the type REINDEX_RECORD was wrong. We were able to fix this by recreating the type:

create or replace TYPE reindex_record AS OBJECT (

  ID INTEGER,

  INODE_TO_INDEX varchar2(36),

  IDENT_TO_INDEX varchar2(36),

  priority INTEGER,

  dist_action INTEGER

)


This solved our headache. It was probably caused by a database restore or maybe an upgrade? We can't think of anything else.


Thanks all for the help!


Xander

Note: Why is the exception in https://github.com/dotCMS/core/blob/3.7.1/src/com/dotcms/journal/business/ESDistributedJournalFactoryImpl.java line 458 wrapped and not logged?

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/37d91b53-c8f5-4768-81f0-cb3365a93378%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.