Running SQL Table creations by hand

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Running SQL Table creations by hand

Miller, Adam
I've run into a situation where I'm pretty sure dotCMS thinks it has created the tables in the database but it has not actually done so and is trying to access the tables and therefore throwing errors telling me the tables are not found. I am running dotCMS Enterprise 2009. I have spoken with the DBA and he said he sees dotCMS making a connection to the database but nothing else in terms of transaction logs. I'm seeing the following errors:

org.quartz.impl.jdbcjobstore.LockException: Failure obtaining db row lock: ORA-00942: table or view does not exist

Any suggestions welcome.

Thank you for your time,

Adam Miller
SHSU UCS : SA-I
GNU/Linux Admin
[hidden email]<mailto:[hidden email]>
Ext. 4-2325

Reply | Threaded
Open this post in threaded view
|

Re: Running SQL Table creations by hand

Jason Tesser-2
Humm not sure what happened for you Adam but it is best to let dotCMS both
create the SQL and run the SQL. If you checkout from SVN you need to run ant
deploy to get it to build.  If you get the binary distro you only need to
config db etc.. and start.

Did any tables get created?
What DB are you using.  If MySQL and on UNIX did you make sure it wasn't
respecting case?

I would start clean with a clean DB.

Thanks,
Jason Tesser
dotCMS Lead Development Manager
1-305-858-1422


On Mon, Dec 14, 2009 at 9:28 AM, Miller, Adam <[hidden email]> wrote:

>
>
>  I’ve run into a situation where I’m pretty sure dotCMS thinks it has
> created the tables in the database but it has not actually done so and is
> trying to access the tables and therefore throwing errors telling me the
> tables are not found. I am running dotCMS Enterprise 2009. I have spoken
> with the DBA and he said he sees dotCMS making a connection to the database
> but nothing else in terms of transaction logs. I’m seeing the following
> errors:
>
>
>
> org.quartz.impl.jdbcjobstore.LockException: Failure obtaining db row lock:
> ORA-00942: table or view does not exist
>
>
>
> Any suggestions welcome.
>
>
>
> Thank you for your time,
>
>
>
> Adam Miller
>
> SHSU UCS : SA-I
>
> GNU/Linux Admin
>
> [hidden email]
>
> Ext. 4-2325
>
>
>
>  
>
Reply | Threaded
Open this post in threaded view
|

Re: Running SQL Table creations by hand

wezell-2
Administrator
Also, I would make sure that the user you are connecting to the db as has
create table/indexes/views/constraints privileges.

Will

----
Will Ezell
www.dotcms.org
phone: 305.858.1422 ext. 286
direct: 978.296.4239
skype: wezell1




On Mon, Dec 14, 2009 at 10:52 AM, Jason Tesser <[hidden email]>wrote:

>
>
> Humm not sure what happened for you Adam but it is best to let dotCMS both
> create the SQL and run the SQL. If you checkout from SVN you need to run ant
> deploy to get it to build.  If you get the binary distro you only need to
> config db etc.. and start.
>
> Did any tables get created?
> What DB are you using.  If MySQL and on UNIX did you make sure it wasn't
> respecting case?
>
> I would start clean with a clean DB.
>
> Thanks,
> Jason Tesser
> dotCMS Lead Development Manager
> 1-305-858-1422
>
>
>
> On Mon, Dec 14, 2009 at 9:28 AM, Miller, Adam <[hidden email]> wrote:
>
>>
>>
>>  I’ve run into a situation where I’m pretty sure dotCMS thinks it has
>> created the tables in the database but it has not actually done so and is
>> trying to access the tables and therefore throwing errors telling me the
>> tables are not found. I am running dotCMS Enterprise 2009. I have spoken
>> with the DBA and he said he sees dotCMS making a connection to the database
>> but nothing else in terms of transaction logs. I’m seeing the following
>> errors:
>>
>>
>>
>> org.quartz.impl.jdbcjobstore.LockException: Failure obtaining db row lock:
>> ORA-00942: table or view does not exist
>>
>>
>>
>> Any suggestions welcome.
>>
>>
>>
>> Thank you for your time,
>>
>>
>>
>> Adam Miller
>>
>> SHSU UCS : SA-I
>>
>> GNU/Linux Admin
>>
>> [hidden email]
>>
>> Ext. 4-2325
>>
>>
>>
>>
>
>
>
>
Reply | Threaded
Open this post in threaded view
|

RE: Running SQL Table creations by hand

Miller, Adam
Jason,
    We are running on Oracle 10g RAC, and I know dotCMS is supposed to function that way because it worked as it is supposed to in our test environment where we used MySQL, but for some reason when installing on production it does not create the tables. So I would like to do so by hand if possible.

Will,
    Our DBAs have assured me the user permissions are correct.

-Adam

Adam Miller
SHSU UCS : SA-I
GNU/Linux Admin
[hidden email]<mailto:[hidden email]>
Ext. 4-2325

From: [hidden email] [mailto:[hidden email]] On Behalf Of Will Ezell
Sent: Monday, December 14, 2009 10:38 AM
To: [hidden email]
Subject: Re: [dotcms] Running SQL Table creations by hand



Also, I would make sure that the user you are connecting to the db as has create table/indexes/views/constraints privileges.

Will

----
Will Ezell
www.dotcms.org<http://www.dotcms.org>
phone: 305.858.1422 ext. 286
direct: 978.296.4239
skype: wezell1



On Mon, Dec 14, 2009 at 10:52 AM, Jason Tesser <[hidden email]<mailto:[hidden email]>> wrote:

Humm not sure what happened for you Adam but it is best to let dotCMS both create the SQL and run the SQL. If you checkout from SVN you need to run ant deploy to get it to build.  If you get the binary distro you only need to config db etc.. and start.

Did any tables get created?
What DB are you using.  If MySQL and on UNIX did you make sure it wasn't respecting case?

I would start clean with a clean DB.

Thanks,
Jason Tesser
dotCMS Lead Development Manager
1-305-858-1422


On Mon, Dec 14, 2009 at 9:28 AM, Miller, Adam <[hidden email]<mailto:[hidden email]>> wrote:

I've run into a situation where I'm pretty sure dotCMS thinks it has created the tables in the database but it has not actually done so and is trying to access the tables and therefore throwing errors telling me the tables are not found. I am running dotCMS Enterprise 2009. I have spoken with the DBA and he said he sees dotCMS making a connection to the database but nothing else in terms of transaction logs. I'm seeing the following errors:

org.quartz.impl.jdbcjobstore.LockException: Failure obtaining db row lock: ORA-00942: table or view does not exist

Any suggestions welcome.

Thank you for your time,

Adam Miller
SHSU UCS : SA-I
GNU/Linux Admin
[hidden email]<mailto:[hidden email]>
Ext. 4-2325






image001.jpg (494 bytes) Download Attachment
image002.jpg (456 bytes) Download Attachment