SAML Plugin for dotCMS 4.x

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

SAML Plugin for dotCMS 4.x

jainaks2010
Hi,

We are upgrading dotCMS from 3.6.2  to 4.1 . We had  been using the SAML plugin from https://github.com/dotCMS/plugin-dotcms-saml . But this plugin does not work on 4.1 . I digged into the code and found that dotCMS is not able to set layout id . There are also some velocity variables which are not able to set.

I found that this version of SAML plugin is depricated and we need to use OpensSAML plugin from https://github.com/dotCMS/plugin-dotcms-openSAML3. But this plugin is not even compiling. Also I did not find any code which is updated as per dotCMS 4 .

Is there any version of SMAL plugin which has been tried and tested on dotcms 4.


Thanks
Akshay Jain

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/df37036f-7ae7-4ad6-8626-96cd3cd35b5f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: SAML Plugin for dotCMS 4.x

Gabby
Hi Jain,

plugin-dotcms-saml has been deprecated for a while, and plugin-dotcms-openSAML3 is indeed the one you need to use.

We are currently working on a 4.x compatible version of this plugin. If you are going to upgrade to dotCMS 4.1.0, you can download the code you need from this branch: https://github.com/dotCMS/plugin-dotcms-openSAML3/tree/release-4.1.x . However, since dotCMS 4.2.0 has already been released, we would recommend you to upgrade to that version and use the following code instead: https://github.com/dotCMS/plugin-dotcms-openSAML3/tree/release-4.2.x .

Best regards,

Gabby


On Tue, Oct 24, 2017 at 8:32 AM Akshay Jain <[hidden email]> wrote:
Hi,

We are upgrading dotCMS from 3.6.2  to 4.1 . We had  been using the SAML plugin from https://github.com/dotCMS/plugin-dotcms-saml . But this plugin does not work on 4.1 . I digged into the code and found that dotCMS is not able to set layout id . There are also some velocity variables which are not able to set.

I found that this version of SAML plugin is depricated and we need to use OpensSAML plugin from https://github.com/dotCMS/plugin-dotcms-openSAML3. But this plugin is not even compiling. Also I did not find any code which is updated as per dotCMS 4 .

Is there any version of SMAL plugin which has been tried and tested on dotcms 4.


Thanks
Akshay Jain

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/df37036f-7ae7-4ad6-8626-96cd3cd35b5f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
--
Gabriela Gonzalez 
Senior Project Manager 
Professional Services 

 3250 Mary Street Suite 405 
Miami, FL 33133 

Main: 305-900-2001
Extension: 7013

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/CALeE254SUmeUdszKyH5ygYy5%3Dt2u3CANSbPBFHDaVCOZ041H1w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.